rootfs-overlay: also exclude .empty files
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Thu, 7 Feb 2013 11:58:10 +0000 (11:58 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 8 Feb 2013 21:11:24 +0000 (22:11 +0100)
This makes it possible to put empty directories in the overlay.
Thanks to Aras Vaichas for pointing that out.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Acked-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile
docs/manual/customize-rootfs.txt

index 395d270c95a67e84b09b35bcb8f09347c2c0214b..7f0822f15f5fbb3362780d7c9824c9d8ac3e58a2 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -506,7 +506,8 @@ endif
        @for dir in $(call qstrip,$(BR2_ROOTFS_OVERLAY)); do \
                $(call MESSAGE,"Copying overlay $${dir}"); \
                rsync -a \
-                       --exclude .svn --exclude .git --exclude .hg --exclude '*~' \
+                       --exclude .empty --exclude .svn --exclude .git \
+                       --exclude .hg --exclude '*~' \
                        $${dir}/ $(TARGET_DIR); \
        done
 
index 3cdbaa1ce9336ff6bb9b05188e19b0a239846da4..b1662cb797f44dce1fe23f8729d7198cfe8f38e4 100644 (file)
@@ -20,8 +20,8 @@ there are a few ways to customize the resulting target filesystem.
 
 * Create a filesystem overlay: a tree of files that are copied directly
   over the target filesystem after it has been built.  Set
-  +BR2_ROOTFS_OVERLAY+ to the top of the tree.  +.git+, +.svn+,
-  +.hg+ directories and files ending with +~+ are excluded.
+  +BR2_ROOTFS_OVERLAY+ to the top of the tree.  +.git+, +.svn+, +.hg+
+  directories, +.empty+ files and files ending with +~+ are excluded.
   _Among these first 3 methods, this one should be preferred_.
 
 * In the Buildroot configuration, you can specify the path to a