package/fmt: bump version to 6.2.0
authorBernd Kuhls <bernd.kuhls@t-online.de>
Fri, 10 Apr 2020 10:39:43 +0000 (12:39 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 10 Apr 2020 20:43:08 +0000 (22:43 +0200)
Added upstream commit to fix Kodi build error.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/fmt/0001-Fix-handling-of-unsigned-char-strings-in-printf.patch [new file with mode: 0644]
package/fmt/fmt.hash
package/fmt/fmt.mk

diff --git a/package/fmt/0001-Fix-handling-of-unsigned-char-strings-in-printf.patch b/package/fmt/0001-Fix-handling-of-unsigned-char-strings-in-printf.patch
new file mode 100644 (file)
index 0000000..41c72aa
--- /dev/null
@@ -0,0 +1,54 @@
+From 7d01859ef16e6b65bc023ad8bebfedecb088bf81 Mon Sep 17 00:00:00 2001
+From: Victor Zverovich <viz@fb.com>
+Date: Wed, 8 Apr 2020 12:32:34 -0700
+Subject: [PATCH] Fix handling of unsigned char strings in printf
+
+Downloaded from upstream commit
+https://github.com/fmtlib/fmt/commit/7d01859ef16e6b65bc023ad8bebfedecb088bf81
+
+to fix Kodi build error:
+https://github.com/xbmc/xbmc/issues/17629
+https://github.com/fmtlib/fmt/issues/1620
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+---
+ include/fmt/core.h  | 8 ++++++++
+ test/printf-test.cc | 6 ++++++
+ 2 files changed, 14 insertions(+)
+
+diff --git a/include/fmt/core.h b/include/fmt/core.h
+index 6df2875ac..dc10722bf 100644
+--- a/include/fmt/core.h
++++ b/include/fmt/core.h
+@@ -972,6 +972,14 @@ template <typename Context> struct arg_mapper {
+     static_assert(std::is_same<char_type, char>::value, "invalid string type");
+     return reinterpret_cast<const char*>(val);
+   }
++  FMT_CONSTEXPR const char* map(signed char* val) {
++    const auto* const_val = val;
++    return map(const_val);
++  }
++  FMT_CONSTEXPR const char* map(unsigned char* val) {
++    const auto* const_val = val;
++    return map(const_val);
++  }
+   FMT_CONSTEXPR const void* map(void* val) { return val; }
+   FMT_CONSTEXPR const void* map(const void* val) { return val; }
+diff --git a/test/printf-test.cc b/test/printf-test.cc
+index 5aaa27b13..545e02aab 100644
+--- a/test/printf-test.cc
++++ b/test/printf-test.cc
+@@ -447,6 +447,12 @@ TEST(PrintfTest, String) {
+   EXPECT_PRINTF(L"    (null)", L"%10s", null_wstr);
+ }
++TEST(PrintfTest, UCharString) {
++  unsigned char str[] = "test";
++  unsigned char* pstr = str;
++  EXPECT_EQ("test", fmt::sprintf("%s", pstr));
++}
++
+ TEST(PrintfTest, Pointer) {
+   int n;
+   void* p = &n;
index 24d05e7789ac52157da82bb9b722c2bbfe1a4bef..29b8237082cd829727db3ad8cfdf4d02f8960717 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 1cafc80701b746085dddf41bd9193e6d35089e1c6ec1940e037fcb9c98f62365  fmt-6.1.2.tar.gz
+sha256 fe6e4ff397e01c379fc4532519339c93da47404b9f6674184a458a9967a76575  fmt-6.2.0.tar.gz
 sha256 825c9324e70f8c839c8ba910543dd4a7daee243b86ef960594c11381a19980b8  LICENSE.rst
index 5dc3088e89c2b89847179c9822b027c01f5031bc..9601141e063a578e5f81c35a805608c36b73bfae 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-FMT_VERSION = 6.1.2
+FMT_VERSION = 6.2.0
 FMT_SITE = $(call github,fmtlib,fmt,$(FMT_VERSION))
 FMT_LICENSE = MIT with exception
 FMT_LICENSE_FILES = LICENSE.rst