package/weston: add support for the RDP compositor
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 21 Feb 2015 22:36:24 +0000 (23:36 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 22 Feb 2015 11:14:18 +0000 (12:14 +0100)
Using the RDP compositor, one can run a headless machine to serve remote
clients, using the RDP protocol.

Add an option to enable the rdp-backend.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Reviewed-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/weston/Config.in
package/weston/weston.mk

index b7f4f27db9e2246df698d7c54fda0a58eaac4cc1..8983460e360bf1099c9928fd80bca96b11be174f 100644 (file)
@@ -39,6 +39,23 @@ config BR2_PACKAGE_WESTON_HAS_COMPOSITOR
 config BR2_PACKAGE_WESTON_FBDEV
        bool "fbdev compositor"
 
+config BR2_PACKAGE_WESTON_RDP
+       bool "RDP compositor"
+       select BR2_PACKAGE_FREERDP
+       select BR2_PACKAGE_WESTON_HAS_COMPOSITOR
+       help
+         This enables the RDP backend, which allows accessing weston
+         through the network with any RDP-compliant client.
+
+         Please note that one must pass those options to weston for RDP
+         to be functional:
+           --rdp-tls-cert=/path/to/server.crt
+           --rdp-tls-key=/path/to/server.key
+
+         By default, Buildroot installs such files in /etc/freerdp/server/
+         so you may want to change them in a post-build script or a rootfs
+         overlay.
+
 # rpi-userland is an EGL/GLES provider, so we can't select it
 config BR2_PACKAGE_WESTON_RPI
        bool "RPi compositor"
index 8a5a891b78d0779e16c9a9dea2f99e5bedc1a6fd..bf49436fe42f8e9a7f663402b14230de490a0dd5 100644 (file)
@@ -31,6 +31,13 @@ else
 WESTON_CONF_OPTS += --disable-libunwind
 endif
 
+ifeq ($(BR2_PACKAGE_WESTON_RDP),y)
+WESTON_DEPENDENCIES += freerdp
+WESTON_CONF_OPTS += --enable-rdp-compositor
+else
+WESTON_CONF_OPTS += --disable-rdp-compositor
+endif
+
 ifeq ($(BR2_PACKAGE_WESTON_FBDEV),y)
 WESTON_CONF_OPTS += --enable-fbdev-compositor
 else