wget: add optional zlib support
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 27 Oct 2017 12:18:58 +0000 (14:18 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 28 Oct 2017 07:10:11 +0000 (09:10 +0200)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/wget/wget.mk

index a7d904405b1422c9cad124bdacceee0fe4fa66b0..3fee8e1b0c2d37f90da33db6bb9ed77fc8973266 100644 (file)
@@ -30,4 +30,11 @@ ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
 WGET_DEPENDENCIES += util-linux
 endif
 
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+WGET_CONF_OPTS += --with-zlib
+WGET_DEPENDENCIES += zlib
+else
+WGET_CONF_OPTS += --without-zlib
+endif
+
 $(eval $(autotools-package))