libupnp: add package libupnp
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Thu, 18 Sep 2008 06:48:20 +0000 (06:48 -0000)
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Thu, 18 Sep 2008 06:48:20 +0000 (06:48 -0000)
This patch adds libupnp package to Buildroot. libupnp provides developers
with an API that are compliant with version 1.0 of the Universal Plug and
Play Device Architecture Specification.

http://pupnp.sourceforge.net/

Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
package/Config.in
package/libupnp/Config.in [new file with mode: 0644]
package/libupnp/libupnp.mk [new file with mode: 0644]

index 9568729ba04fa0a3d726cc1fb920b37331774655..d6babe344500fd926ef63558f23170062d22a06a 100644 (file)
@@ -163,6 +163,7 @@ source "package/libcgicc/Config.in"
 source "package/libeXosip2/Config.in"
 source "package/libosip2/Config.in"
 source "package/libpcap/Config.in"
+source "package/libupnp/Config.in"
 if !BR2_PACKAGE_BUSYBOX_HIDE_OTHERS
 source "package/lighttpd/Config.in"
 endif
diff --git a/package/libupnp/Config.in b/package/libupnp/Config.in
new file mode 100644 (file)
index 0000000..6b1a6cf
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LIBUPNP
+       bool "libupnp"
+       help
+         The portable SDK for UPnP(tm) Devices (libupnp) provides developers
+         with an API and open source code for building control points,
+         devices, and bridges that are compliant with Version 1.0 of the
+         Universal Plug and Play Device Architecture Specification
+
+         http://pupnp.sourceforge.net/
diff --git a/package/libupnp/libupnp.mk b/package/libupnp/libupnp.mk
new file mode 100644 (file)
index 0000000..9cd2e7f
--- /dev/null
@@ -0,0 +1,13 @@
+#############################################################
+#
+# libupnp
+#
+#############################################################
+LIBUPNP_VERSION:=1.6.6
+LIBUPNP_SOURCE:=libupnp-$(LIBUPNP_VERSION).tar.bz2
+LIBUPNP_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/pupnp
+
+LIBUPNP_INSTALL_STAGING:=YES
+LIBUPNP_INSTALL_TARGET_OPT:=DESTDIR=$(TARGET_DIR) install-strip
+
+$(eval $(call AUTOTARGETS,package,libupnp))