package/rapidxml: fix install path
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 7 Apr 2019 19:42:46 +0000 (21:42 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 10 Apr 2019 17:08:20 +0000 (19:08 +0200)
kodi-pvr-iptvsimple as of
https://github.com/kodi-pvr/pvr.iptvsimple/commit/d27b3ed1d379d2f865e95f08bdf2dbf086f8c0ad

depends on rapidxml but expects the headers in usr/include/rapidxml
instead of usr/include.

This changes the install path to be consistent with Debian and Gentoo:

https://packages.debian.org/stretch/all/librapidxml-dev/filelist
https://gitweb.gentoo.org/repo/gentoo.git/tree/dev-libs/rapidxml/rapidxml-1.13-r1.ebuild#n22

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/rapidxml/rapidxml.mk

index 9d034d820599d3ec556a19a06c03012c134c9e1f..ef2dd3972b4895e3e3ef53a4441666ac9911435a 100644 (file)
@@ -21,7 +21,8 @@ define RAPIDXML_EXTRACT_CMDS
 endef
 
 define RAPIDXML_INSTALL_STAGING_CMDS
-       cp -dpfr $(@D)/*hpp $(STAGING_DIR)/usr/include
+       mkdir -p $(STAGING_DIR)/usr/include/rapidxml
+       cp -dpfr $(@D)/*hpp $(STAGING_DIR)/usr/include/rapidxml
 endef
 
 $(eval $(generic-package))