haproxy: fix linking with lua
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 28 Sep 2018 17:35:19 +0000 (19:35 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Oct 2018 13:16:50 +0000 (15:16 +0200)
Use LUA_LIB_NAME to give lua library name otherwise haproxy can't find
it

Fixes:
 - http://autobuild.buildroot.net/results/28b6672188bb0082ac1467d3b45904880e3634f3

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/haproxy/haproxy.mk

index a799e696510f0115a9fff258206cd5ad1b05bb5f..363fc4447f1219b621ac13d4126016c7ed550cbb 100644 (file)
@@ -25,7 +25,9 @@ endif
 
 ifeq ($(BR2_PACKAGE_LUA_5_3),y)
 HAPROXY_DEPENDENCIES += lua
-HAPROXY_MAKE_OPTS += USE_LUA=1
+HAPROXY_MAKE_OPTS += \
+       LUA_LIB_NAME=lua \
+       USE_LUA=1
 endif
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)