package/kodi-peripheral-steamcontroller: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 7 May 2017 11:32:04 +0000 (13:32 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 16 Jul 2017 14:12:25 +0000 (16:12 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kodi-peripheral-steamcontroller/Config.in [new file with mode: 0644]
package/kodi-peripheral-steamcontroller/kodi-peripheral-steamcontroller.hash [new file with mode: 0644]
package/kodi-peripheral-steamcontroller/kodi-peripheral-steamcontroller.mk [new file with mode: 0644]
package/kodi/Config.in

diff --git a/package/kodi-peripheral-steamcontroller/Config.in b/package/kodi-peripheral-steamcontroller/Config.in
new file mode 100644 (file)
index 0000000..a994f4c
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_KODI_PERIPHERAL_STEAMCONTROLLER
+       bool "kodi-peripheral-steamcontroller"
+       select BR2_PACKAGE_KODI_PLATFORM
+       select BR2_PACKAGE_LIBUSB
+       help
+         Steam controller driver for Kodi
+
+         https://github.com/kodi-game/peripheral.steamcontroller
diff --git a/package/kodi-peripheral-steamcontroller/kodi-peripheral-steamcontroller.hash b/package/kodi-peripheral-steamcontroller/kodi-peripheral-steamcontroller.hash
new file mode 100644 (file)
index 0000000..c0b3bf6
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed
+sha256 d5547b78ba84c9743c884a9377c398b540bfcf23e467e1edf8be2625d400c205  kodi-peripheral-steamcontroller-ef527cd81cfcd6c8342691f5c764e5c51df1fca2.tar.gz
diff --git a/package/kodi-peripheral-steamcontroller/kodi-peripheral-steamcontroller.mk b/package/kodi-peripheral-steamcontroller/kodi-peripheral-steamcontroller.mk
new file mode 100644 (file)
index 0000000..98cccc8
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# kodi-peripheral-steamcontroller
+#
+################################################################################
+
+KODI_PERIPHERAL_STEAMCONTROLLER_VERSION = ef527cd81cfcd6c8342691f5c764e5c51df1fca2
+KODI_PERIPHERAL_STEAMCONTROLLER_SITE = $(call github,kodi-game,peripheral.steamcontroller,$(KODI_PERIPHERAL_STEAMCONTROLLER_VERSION))
+KODI_PERIPHERAL_STEAMCONTROLLER_LICENSE = GPL-2.0+
+KODI_PERIPHERAL_STEAMCONTROLLER_LICENSE_FILES = src/addon.cpp
+KODI_PERIPHERAL_STEAMCONTROLLER_DEPENDENCIES = kodi-platform libusb
+
+$(eval $(cmake-package))
index efb613ae0629f37bafd719aac17a761d52566f4c..50dc2ff58070a7eac6478c16e82d4c5417db5ea7 100644 (file)
@@ -295,6 +295,7 @@ endmenu
 
 menu "Peripheral addons"
        source "package/kodi-peripheral-joystick/Config.in"
+       source "package/kodi-peripheral-steamcontroller/Config.in"
 endmenu
 
 menu "PVR addons"