gpsd: disable Python support
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 25 Jul 2012 16:24:05 +0000 (18:24 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 25 Jul 2012 16:25:42 +0000 (18:25 +0200)
The Python support is not cross-compile friendly (uses host compiler,
installs in wrong location, etc.) and nobody needs it at the moment,
so leave that to the first person who will need Python support for
gpsd.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gpsd/gpsd.mk

index e96d9797909ae19cdb6d6e2393d75bbb1d4f6f40..190732f092364d11b8f7065f7ca15d2f291117b8 100644 (file)
@@ -20,7 +20,8 @@ GPSD_SCONS_OPTS = \
        prefix=/usr\
        chrpath=no\
        sysroot=$(STAGING_DIR)\
-       strip=no
+       strip=no\
+       python=no
 
 ifeq ($(BR2_PACKAGE_NCURSES),y)
        GPSD_DEPENDENCIES += ncurses
@@ -29,12 +30,6 @@ else
        GPSD_SCONS_OPTS += ncurses=no
 endif
 
-ifeq ($(BR2_PACKAGE_PYTHON),y)
-       GPSD_DEPENDENCIES += python
-else
-       GPSD_SCONS_OPTS += python=no
-endif
-
 # Disable IPv6, if we don't support it
 ifneq ($(BR2_INET_IPV6),y)
        GPSD_SCONS_OPTS += ipv6=no