numactl: new package
authorWill Newton <will.newton@imgtec.com>
Sun, 26 May 2013 12:08:11 +0000 (12:08 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 27 May 2013 08:41:16 +0000 (10:41 +0200)
[Thomas: updated to 2.0.8, restricted to supported architectures,
added licensing informations, updated to latest Buildroot package
infrastructure]

[Peter: Fix LICENSE_FILES typo, needs largefile support in toolchain]
Signed-off-by: Will Newton <will.newton@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/numactl/Config.in [new file with mode: 0644]
package/numactl/numactl.mk [new file with mode: 0644]

index 52a0735203066fdbe879db6e7f16aff9b6095802..8bf1652cb48d29ba0219f9e629599c317e69afd9 100644 (file)
@@ -859,6 +859,7 @@ source "package/module-init-tools/Config.in"
 endif
 source "package/monit/Config.in"
 source "package/ncdu/Config.in"
+source "package/numactl/Config.in"
 source "package/polkit/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/procps/Config.in"
diff --git a/package/numactl/Config.in b/package/numactl/Config.in
new file mode 100644 (file)
index 0000000..21e76fb
--- /dev/null
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_NUMACTL
+       bool "numactl"
+       # numactl uses some system calls that are not available on all
+       # architectures.
+       depends on BR2_LARGEFILE
+       depends on BR2_i386 || BR2_mips || BR2_mipsel || \
+                  BR2_mips64 || BR2_mips64el || BR2_powerpc || BR2_x86_64
+       help
+         numactl allows you to run your application on specific cpus
+         and memory nodes. It does this by supplying a NUMA memory
+         policy to the operating system before running your program.
+
+         http://oss.sgi.com/projects/libnuma/
+
+comment "numactl requires a toolchain with LARGEFILE support"
+       depends on !BR2_LARGEFILE
diff --git a/package/numactl/numactl.mk b/package/numactl/numactl.mk
new file mode 100644 (file)
index 0000000..fe6f23f
--- /dev/null
@@ -0,0 +1,21 @@
+#############################################################
+#
+# numactl
+#
+#############################################################
+
+NUMACTL_VERSION = 2.0.8
+NUMACTL_SOURCE = numactl-$(NUMACTL_VERSION).tar.gz
+NUMACTL_SITE = ftp://oss.sgi.com/www/projects/libnuma/download/
+NUMACTL_LICENSE = LGPLv2.1 (libnuma), GPLv2 (programs)
+NUMACTL_LICENSE_FILES = README
+
+define NUMACTL_BUILD_CMDS
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define NUMACTL_INSTALL_TARGET_CMDS
+       $(MAKE) prefix=$(TARGET_DIR) libdir=$(TARGET_DIR)/lib -C $(@D) install
+endef
+
+$(eval $(generic-package))