autotools: allow host package to use <pkg>_MAKE_ENV and <pkg>_MAKE
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 23 Jan 2011 16:08:53 +0000 (17:08 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 25 Jan 2011 07:59:56 +0000 (08:59 +0100)
This will be needed by the Python interpreter package.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Makefile.autotools.in

index de0a3557569b89a0398f6040c81cfaa0bb89ce24..d445348d2bcbcd9eb36574debafb3e24fb7a21e0 100644 (file)
@@ -200,7 +200,7 @@ endif
 #
 ifndef $(2)_INSTALL_CMDS
 define $(2)_INSTALL_CMDS
-       $(HOST_MAKE_ENV) $(MAKE) -C $$($$(PKG)_SRCDIR) install
+       $(HOST_MAKE_ENV) $$($$(PKG)_MAKE_ENV) $$($$(PKG)_MAKE) -C $$($$(PKG)_SRCDIR) install
 endef
 endif