package/liblo: fix build with musl
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 8 Apr 2018 09:37:06 +0000 (11:37 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 9 Apr 2018 09:23:11 +0000 (11:23 +0200)
Commit 2759ba03979 (liblo: disable werror to fix build issues) tried to
fix the issue by passing --disable-werror, but this is not a recognised
option.

Instead, just fix the code for good.

Fixes:
    http://autobuild.buildroot.org/results/000a46954d0c6d3dbc4b4634a0d3a3c955fac679
    http://autobuild.buildroot.org/results/58cb834bbd69bafc5cb0f23c236919c609648c05
    http://autobuild.buildroot.org/results/9de1c2007818082e88d77572abf8ff8a72e01930
    ...

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Alex Baldwin <alexbaldwinmusic@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/liblo/0001-server-use-correct-poll.h-header.patch [new file with mode: 0644]
package/liblo/liblo.mk

diff --git a/package/liblo/0001-server-use-correct-poll.h-header.patch b/package/liblo/0001-server-use-correct-poll.h-header.patch
new file mode 100644 (file)
index 0000000..04c0445
--- /dev/null
@@ -0,0 +1,32 @@
+From d59f2e6f42a9e4f8a9184d7ed75546f47dc50123 Mon Sep 17 00:00:00 2001
+From: "Yann E. MORIN" <yann.morin.1998@free.fr>
+Date: Sun, 8 Apr 2018 11:09:02 +0200
+Subject: [PATCH] server: use correct poll.h header
+
+Fixes build with the musl C library:
+    http://autobuild.buildroot.net/results/000a46954d0c6d3dbc4b4634a0d3a3c955fac679
+
+Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
+---
+Upstream status:
+  PR sent: https://github.com/radarsat1/liblo/pull/66
+---
+ src/server.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/server.c b/src/server.c
+index 01fa08f..11c62d2 100644
+--- a/src/server.c
++++ b/src/server.c
+@@ -51,7 +51,7 @@
+ #include <netdb.h>
+ #include <sys/socket.h>
+ #ifdef HAVE_POLL
+-#include <sys/poll.h>
++#include <poll.h>
+ #endif
+ #include <sys/un.h>
+ #include <arpa/inet.h>
+-- 
+2.14.1
+
index 7845c68ff26b9ab8e67bb7c649a0b1190ea6141f..e28e52803a25d7e9df7ac8f0fc566d049bf690b7 100644 (file)
@@ -12,10 +12,7 @@ LIBLO_LICENSE_FILES = COPYING
 LIBLO_INSTALL_STAGING = YES
 
 # IPv6 support broken, issue known upstream
-# werror - not needed for release.
-LIBLO_CONF_OPTS += \
-       --disable-ipv6 \
-       --disable-werror
+LIBLO_CONF_OPTS = --disable-ipv6
 
 # Liblo uses atomic builtins, so we need to link with libatomic for
 # the architectures who explicitly need libatomic.