scons: fix library installation directory
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 9 Oct 2012 12:25:56 +0000 (12:25 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 11 Oct 2012 20:28:18 +0000 (22:28 +0200)
On gentoo systems SCons setup.py tries to install into
$(HOST_DIR)/usr/lib64 but SCons looks up for its stuff in
$(HOST_DIR)/usr/lib instead hence breaking.
Make it install into $(HOST_DIR)/usr/lib by force to avoid the issue, it
shouldn't matter on other distributions.
Version bumping doesn't fix it.

[Peter: wrapped long line]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/scons/scons.mk

index 2aed62c5cbbb22db870214a0cc8526fef3d84ff1..7cc234e8b8395ebd345c1ab7cf7df8461aff5ae1 100644 (file)
@@ -7,7 +7,8 @@ define HOST_SCONS_BUILD_CMDS
 endef
 
 define HOST_SCONS_INSTALL_CMDS
-       (cd $(@D); python setup.py install --prefix=$(HOST_DIR)/usr)
+       (cd $(@D); python setup.py install --prefix=$(HOST_DIR)/usr \
+               --install-lib=$(HOST_DIR)/usr/lib/scons-$(SCONS_VERSION))
 endef
 
 $(eval $(host-generic-package))