ffmpeg: disable MIPS DSP options by default
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Wed, 14 Oct 2015 15:58:22 +0000 (16:58 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 14 Oct 2015 20:30:19 +0000 (22:30 +0200)
DSP support depends on the core implementation, not on the ISA, so
enabling it for mips64r2 is not correct since you can build a mips64r2
core without DSP support.

Disable mipsdspr1 and mipsdspr2 options by default and let the user
enable them via the BR2_PACKAGE_FFMPEG_EXTRACONF kconfig option, which
will take preference and override the default values.

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ffmpeg/ffmpeg.mk

index 4f4c52cbd30b8328170a53d827ce3053b484e084..fd953d6152e11a576a0a71934bec19457fe5075d 100644 (file)
@@ -41,6 +41,8 @@ FFMPEG_CONF_OPTS = \
        --enable-runtime-cpudetect \
        --disable-hardcoded-tables \
        --disable-memalign-hack \
+       --disable-mipsdspr1 \
+       --disable-mipsdspr2 \
        --disable-msa \
        --enable-hwaccels \
        --disable-avisynth \
@@ -355,16 +357,6 @@ FFMPEG_CONF_OPTS += \
        --disable-mips32r2
 endif
 
-ifeq ($(BR2_mips_64r2),y)
-FFMPEG_CONF_OPTS += \
-       --enable-mipsdspr1 \
-       --enable-mipsdspr2
-else
-FFMPEG_CONF_OPTS += \
-       --disable-mipsdspr1 \
-       --disable-mipsdspr2
-endif
-
 ifeq ($(BR2_POWERPC_CPU_HAS_ALTIVEC),y)
 FFMPEG_CONF_OPTS += --enable-altivec
 else