package/tvheadend: add support for host-python3
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 16 Nov 2014 12:26:26 +0000 (13:26 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 18 Nov 2014 21:50:54 +0000 (22:50 +0100)
Added upstream:
https://github.com/tvheadend/tvheadend/commit/5a07ff166a84c65f08d326c69c818f6eef315e68

Tested with these defconfigs:

BR2_TOOLCHAIN_BUILDROOT_LARGEFILE=y
BR2_TOOLCHAIN_BUILDROOT_INET_IPV6=y
BR2_TOOLCHAIN_BUILDROOT_WCHAR=y
BR2_PACKAGE_PYTHON3=y
BR2_PACKAGE_TVHEADEND=y

BR2_TOOLCHAIN_BUILDROOT_LARGEFILE=y
BR2_TOOLCHAIN_BUILDROOT_INET_IPV6=y
BR2_TOOLCHAIN_BUILDROOT_WCHAR=y
BR2_PACKAGE_PYTHON=y
BR2_PACKAGE_TVHEADEND=y

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/tvheadend/tvheadend.mk

index 0b564f676d739e15e7c389d13e2013222d852592..b0038c836719c35a8849d65350672d861d9144a7 100644 (file)
@@ -8,7 +8,7 @@ TVHEADEND_VERSION = fcd16fa0d835d7fd4f57c350ed8b76350440c68c
 TVHEADEND_SITE = $(call github,tvheadend,tvheadend,$(TVHEADEND_VERSION))
 TVHEADEND_LICENSE = GPLv3+
 TVHEADEND_LICENSE_FILES = LICENSE.md
-TVHEADEND_DEPENDENCIES = host-pkgconf host-python openssl
+TVHEADEND_DEPENDENCIES = host-pkgconf $(if $(BR2_PACKAGE_PYTHON3),host-python3,host-python) openssl
 
 ifeq ($(BR2_PACKAGE_AVAHI),y)
 TVHEADEND_DEPENDENCIES += avahi
@@ -42,7 +42,7 @@ define TVHEADEND_CONFIGURE_CMDS
         --prefix=/usr                          \
         --arch="$(ARCH)"                       \
         --cpu="$(BR2_GCC_TARGET_CPU)"          \
-        --python="$(HOST_DIR)/usr/bin/python2" \
+        --python="$(HOST_DIR)/usr/bin/python \
         --disable-dvbscan                      \
         --enable-bundle                        \
         --disable-libffmpeg_static             \