i.MX: Update versions to match latest Freescale release
authorEric Nelson <eric.nelson@boundarydevices.com>
Fri, 14 Feb 2014 00:26:19 +0000 (17:26 -0700)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 14 Feb 2014 20:16:52 +0000 (21:16 +0100)
Signed-off-by: Eric Nelson <eric.nelson@boundarydevices.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/freescale-imx/freescale-imx.mk
package/freescale-imx/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.mk
package/freescale-imx/imx-lib/imx-lib.mk
package/gstreamer/gst-fsl-plugins/gst-fsl-plugins.mk
package/libfslcodec/libfslcodec.mk
package/libfslparser/libfslparser.mk
package/libfslvpuwrap/libfslvpuwrap.mk

index 0dd56296c344f9a3ca99531bccf6afdcabfdf077..39ffa8ac68d9e8a5cc00ec191067938f26d4eef3 100644 (file)
@@ -4,9 +4,7 @@
 #
 ################################################################################
 
-FREESCALE_IMX_VERSION = 1.1.0
-
-# No official download site from freescale, just this mirror
-FREESCALE_IMX_SITE   = http://download.ossystems.com.br/bsp/freescale/source
+FREESCALE_IMX_VERSION = 3.5.7-1.0.0
+FREESCALE_IMX_SITE    = http://www.freescale.com/lgfiles/NMG/MAD/YOCTO/
 
 include $(sort $(wildcard package/freescale-imx/*/*.mk))
index 8e979ee51bf4425ddf64c7015c8a9e9d29a848e5..e799fd2a5e4c717c03a85cd56c9cdc564e3d4ee6 100644 (file)
@@ -4,7 +4,11 @@
 #
 ################################################################################
 
-GPU_VIV_BIN_MX6Q_VERSION = $(FREESCALE_IMX_VERSION)
+ifeq ($(BR2_ARM_EABIHF),y)
+GPU_VIV_BIN_MX6Q_VERSION = $(FREESCALE_IMX_VERSION)-hfp
+else
+GPU_VIV_BIN_MX6Q_VERSION = $(FREESCALE_IMX_VERSION)-sfp
+endif
 GPU_VIV_BIN_MX6Q_SITE    = $(FREESCALE_IMX_SITE)
 GPU_VIV_BIN_MX6Q_SOURCE  = gpu-viv-bin-mx6q-$(GPU_VIV_BIN_MX6Q_VERSION).bin
 
index e1a68ef85cd0124ebd843320e49d5781cb3f17d5..4f605d70a2d320e85f94408ce3bf668b03662293 100644 (file)
@@ -6,8 +6,9 @@
 
 IMX_LIB_VERSION = $(FREESCALE_IMX_VERSION)
 IMX_LIB_SITE    = $(FREESCALE_IMX_SITE)
-IMX_LIB_LICENSE = LGPLv2.1+
-# No license file included
+IMX_LIB_LICENSE = Freescale License (vpu), LGPLv2.1+ (the rest)
+IMX_LIB_LICENSE_FILES = EULA
+IMX_LIB_SOURCE = imx-lib-$(IMX_LIB_VERSION).bin
 
 IMX_LIB_INSTALL_STAGING = YES
 
@@ -25,6 +26,23 @@ IMX_LIB_MAKE_ENV = \
        PLATFORM=$(BR2_PACKAGE_IMX_LIB_PLATFORM) \
        INCLUDE="$(IMX_LIB_INCLUDE)"
 
+# The archive is a shell-self-extractor of a bzipped tar. It happens
+# to extract in the correct directory (imx-lib-x.y.z)
+# The --force makes sure it doesn't fail if the source dir already exists.
+# The --auto-accept skips the license check - not needed for us
+# because we have legal-info
+# Since there's a EULA in the bin file, extract it to imx-lib-x.y.z/EULA
+#
+define IMX_LIB_EXTRACT_CMDS
+       awk 'BEGIN      { start=0; } \
+            /^EOEULA/  { start = 0; } \
+                       { if (start) print; } \
+            /<<EOEULA/ { start=1; }'\
+           $(DL_DIR)/$(IMX_LIB_SOURCE) > $(@D)/EULA
+       cd $(BUILD_DIR); \
+       sh $(DL_DIR)/$(IMX_LIB_SOURCE) --force --auto-accept
+endef
+
 define IMX_LIB_BUILD_CMDS
        $(IMX_LIB_MAKE_ENV) $(MAKE1) -C $(@D)
 endef
index 44378759fbfb06e266366d1d3fa870d44be99c5e..9ec92d845095ae561c7576b15b96b7c4c9f9f28f 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-GST_FSL_PLUGINS_VERSION = 3.0.1
+GST_FSL_PLUGINS_VERSION = $(FREESCALE_IMX_VERSION)
 GST_FSL_PLUGINS_SITE = $(FREESCALE_IMX_SITE)
 
 # Most is LGPLv2+, but some sources are copied from upstream and are
index ad1cc633330c8ade98da401369343ee984efc3b8..d52158ccc64b7d95c389d670622bd82e045a6b80 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBFSLCODEC_VERSION = 3.0.1
+LIBFSLCODEC_VERSION = $(FREESCALE_IMX_VERSION)
 LIBFSLCODEC_SITE = $(FREESCALE_IMX_SITE)
 LIBFSLCODEC_SOURCE = libfslcodec-$(LIBFSLCODEC_VERSION).bin
 LIBFSLCODEC_LICENSE = Freescale Semiconductor Software License Agreement, BSD-3c (flac, ogg headers)
index 3aab3a7b35001ddfe71de45b93ec4cadba4e6cdf..0d92e02091bdf64409136cd3109df381653a9537 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBFSLPARSER_VERSION = 3.0.1
+LIBFSLPARSER_VERSION = $(FREESCALE_IMX_VERSION)
 LIBFSLPARSER_SITE = $(FREESCALE_IMX_SITE)
 LIBFSLPARSER_SOURCE = libfslparser-$(LIBFSLPARSER_VERSION).bin
 LIBFSLPARSER_LICENSE = Freescale Semiconductor Software License Agreement
@@ -36,4 +36,7 @@ endef
 # The Makefile installs several versions of the libraries, but we only
 # need one of them, depending on the platform.
 
+# without AUTORECONF, configure fails to find install-sh.
+LIBFSLPARSER_AUTORECONF = YES
+
 $(eval $(autotools-package))
index 346a20a49814709ffdb7dcb6ca46754517abe0dd..75c988779dd077dbe3ea9582a45477acf0b9ab91 100644 (file)
@@ -4,14 +4,33 @@
 #
 ################################################################################
 
-LIBFSLVPUWRAP_VERSION = 1.0.17
+LIBFSLVPUWRAP_VERSION = $(FREESCALE_IMX_VERSION)
 LIBFSLVPUWRAP_SITE = $(FREESCALE_IMX_SITE)
+LIBFSLVPUWRAP_SOURCE = libfslvpuwrap-$(LIBFSLVPUWRAP_VERSION).bin
 LIBFSLVPUWRAP_LICENSE = Freescale Semiconductor Software License Agreement
-LIBFSLVPUWRAP_LICENSE_FILES = EULA.txt
+# N.B.: the content of the two license files is different
+LIBFSLVPUWRAP_LICENSE_FILES = EULA EULA.txt
 LIBFSLVPUWRAP_REDISTRIBUTE = NO
 
 LIBFSLVPUWRAP_INSTALL_STAGING = YES
 
 LIBFSLVPUWRAP_DEPENDENCIES += imx-lib
 
+# The archive is a shell-self-extractor of a bzipped tar. It happens
+# to extract in the correct directory (libfslvpuwrap-x.y.z)
+# The --force makes sure it doesn't fail if the source dir already exists.
+# The --auto-accept skips the license check - not needed for us
+# because we have legal-info
+# Since the EULA in the bin file differs from the one in the tar file,
+# extract the one from the bin file as well.
+define LIBFSLVPUWRAP_EXTRACT_CMDS
+       awk 'BEGIN      { start=0; } \
+            /^EOEULA/  { start = 0; } \
+                       { if (start) print; } \
+            /<<EOEULA/ { start=1; }'\
+           $(DL_DIR)/$(LIBFSLVPUWRAP_SOURCE) > $(@D)/EULA
+       cd $(BUILD_DIR); \
+       sh $(DL_DIR)/$(LIBFSLVPUWRAP_SOURCE) --force --auto-accept
+endef
+
 $(eval $(autotools-package))