iputils: fix ping and traceroute6 executable permissions
authorEinar Jon Gunnarsson <tolvupostur@gmail.com>
Sat, 13 Jan 2018 20:19:42 +0000 (21:19 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 17 Jan 2018 22:22:52 +0000 (23:22 +0100)
The iputils executables are installed without the setuid bit set,
which prevents some programs from working.

This patch adds a permission table to fix the permissions of the ping
and traceroute6 executables.

Signed-off-by: Einar Jon Gunnarsson <tolvupostur@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/iputils/iputils.mk

index b20cd12b7ac24ba07798d788a7bab931ee6723cf..13e33898d64f7b2f30a519adfb317df059ce57d0 100644 (file)
@@ -69,4 +69,9 @@ define IPUTILS_INSTALL_TARGET_CMDS
        $(INSTALL) -D -m 755 $(@D)/traceroute6 $(TARGET_DIR)/bin/traceroute6
 endef
 
+define IPUTILS_PERMISSIONS
+       /bin/ping        f 4755 0 0 - - - - -
+       /bin/traceroute6 f 4755 0 0 - - - - -
+endef
+
 $(eval $(generic-package))