python-socketio: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Fri, 1 Jul 2016 10:06:19 +0000 (12:06 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 1 Jul 2016 13:04:55 +0000 (15:04 +0200)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-socketio/Config.in [new file with mode: 0644]
package/python-socketio/python-socketio.hash [new file with mode: 0644]
package/python-socketio/python-socketio.mk [new file with mode: 0644]

index a2d08a1bb3a3dbf8e7446845f4999e8fd52615b5..8eeca31120e63d706f6691d9257b6f803e1f9403 100644 (file)
@@ -766,6 +766,7 @@ menu "External python modules"
        source "package/python-sip/Config.in"
        source "package/python-six/Config.in"
        source "package/python-smbus-cffi/Config.in"
+       source "package/python-socketio/Config.in"
        source "package/python-spidev/Config.in"
        source "package/python-thrift/Config.in"
        source "package/python-tornado/Config.in"
diff --git a/package/python-socketio/Config.in b/package/python-socketio/Config.in
new file mode 100644 (file)
index 0000000..af0f6f3
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PYTHON_SOCKETIO
+       bool "python-socketio"
+       select BR2_PACKAGE_PYTHON_SIX # runtime
+       select BR2_PACKAGE_PYTHON_ENGINEIO # runtime
+       help
+         Socket.IO server.
+
+         http://github.com/miguelgrinberg/python-socketio/
diff --git a/package/python-socketio/python-socketio.hash b/package/python-socketio/python-socketio.hash
new file mode 100644 (file)
index 0000000..659d4d5
--- /dev/null
@@ -0,0 +1,4 @@
+# md5 from https://pypi.python.org/pypi/python-socketio/json
+md5    44fd24e839dc3102920765f345740646  python-socketio-1.4.1.tar.gz
+# sha256 calculated by scanpypi
+sha256 ebd0984d831d602c8ec6d586ecde4466972cc7ed37dbbfe613192864e8263779  python-socketio-1.4.1.tar.gz
diff --git a/package/python-socketio/python-socketio.mk b/package/python-socketio/python-socketio.mk
new file mode 100644 (file)
index 0000000..3bcfed1
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-socketio
+#
+################################################################################
+
+PYTHON_SOCKETIO_VERSION = 1.4.1
+PYTHON_SOCKETIO_SOURCE = python-socketio-$(PYTHON_SOCKETIO_VERSION).tar.gz
+PYTHON_SOCKETIO_SITE = https://pypi.python.org/packages/da/00/66103df6a116a2ce3ea662a9c8c80f337d43d7f138caf04e9af6dec24ba7
+PYTHON_SOCKETIO_SETUP_TYPE = setuptools
+PYTHON_SOCKETIO_LICENSE = MIT
+PYTHON_SOCKETIO_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))