package/libressl: fix openssldir setting to match openssl
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 16 Jun 2021 16:05:06 +0000 (18:05 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 23 Jun 2021 06:53:37 +0000 (08:53 +0200)
libressl defaults to $prefix/etc/ssl for its "openssldir" setting, E.G.
the location where configuration files and certificates are searched:

openssl version -d
OPENSSLDIR: "/usr/etc/ssl"

Change it to /etc/ssl so it matches openssl and the expectations of packages
dealing with certificates (ca-certificates, libcurl, p11-kit)

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libressl/libressl.mk

index ad345ba3f0910e67a86b32985b6081c44bdd93c8..d09df8f40f22f95243a4bc6004d28c7b74e30a20 100644 (file)
@@ -10,6 +10,7 @@ LIBRESSL_LICENSE = ISC (new additions), OpenSSL or SSLeay (original OpenSSL code
 LIBRESSL_LICENSE_FILES = COPYING
 LIBRESSL_CPE_ID_VENDOR = openbsd
 LIBRESSL_INSTALL_STAGING = YES
+LIBRESSL_CONF_OPTS = -DOPENSSLDIR="/etc/ssl"
 
 ifeq ($(BR2_PACKAGE_LIBRESSL_BIN),)
 define LIBRESSL_REMOVE_BIN