postgresql: bump to 10.1
authorAdam Duskett <aduskett@gmail.com>
Sat, 25 Nov 2017 17:12:14 +0000 (12:12 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 27 Nov 2017 08:44:24 +0000 (09:44 +0100)
- Add a hash for the license file.

- PostgreSQL 10.0 and above will default to checking for /dev/urandom if an
  SSL library is not found, which will fail when cross compiling.
  Since /dev/urandom is guaranteed to be provided on Linux systems,
  add ac_cv_file__dev_urandom=yes to the configure environment if a SSL library
  is not selected.

Signed-off-by: Adam Duskett <Adamduskett@outlook.com>
[Thomas: minor tweaks to the /dev/urandom comment in the .mk file.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/postgresql/postgresql.hash
package/postgresql/postgresql.mk

index e62838911e31c6a7281ce5f61f58e9564111ed20..e2347701c19db6b1f6f26007b6a1f93f150a6376 100644 (file)
@@ -1,4 +1,5 @@
-# From https://ftp.postgresql.org/pub/source/v9.6.6/postgresql-9.6.6.tar.bz2.sha256
-sha256 399cdffcb872f785ba67e25d275463d74521566318cfef8fe219050d063c8154  postgresql-9.6.6.tar.bz2
+# From https://ftp.postgresql.org/pub/source/v10.1/postgresql-10.1.tar.bz2.sha256
+sha256 3ccb4e25fe7a7ea6308dea103cac202963e6b746697366d72ec2900449a5e713        postgresql-10.1.tar.bz2
+
 # License file, Locally calculated
-sha256 7dc8de32741ad1b03e21710771b55a1b9d460671d47f28a8840f917e38c66676  COPYRIGHT
+sha256 7dc8de32741ad1b03e21710771b55a1b9d460671d47f28a8840f917e38c66676        COPYRIGHT
index 50ce212c1c4dbfeea3d6f14164db2ed3832d1cd0..4657489a53f89ff72778f19a210bbc9ad359ea1c 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-POSTGRESQL_VERSION = 9.6.6
+POSTGRESQL_VERSION = 10.1
 POSTGRESQL_SOURCE = postgresql-$(POSTGRESQL_VERSION).tar.bz2
 POSTGRESQL_SITE = http://ftp.postgresql.org/pub/source/v$(POSTGRESQL_VERSION)
 POSTGRESQL_LICENSE = PostgreSQL
@@ -56,6 +56,11 @@ endif
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 POSTGRESQL_DEPENDENCIES += openssl
 POSTGRESQL_CONF_OPTS += --with-openssl
+else
+# PostgreSQL checks for /dev/urandom and fails if it's being cross-compiled and
+# an SSL library isn't found. Since /dev/urandom is guaranteed to be provided
+# on Linux systems, explicitly tell the configure script it's available.
+POSTGRESQL_CONF_ENV += ac_cv_file__dev_urandom=yes
 endif
 
 ifeq ($(BR2_PACKAGE_OPENLDAP),y)