Add back rootfs-* dependencies to "source" and "legal-info" targets
authorFabio Porcedda <fabio.porcedda@gmail.com>
Thu, 13 Mar 2014 16:06:59 +0000 (17:06 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 29 Mar 2014 11:08:59 +0000 (12:08 +0100)
After adding support top-level parallel make the rootfs-* dependencies
were not anymore considered for the "source" and "legal-info" targets
because the rootfs-* targets were removed from TARGETS variable and
placed in the TARGETS_ROOTFS variable so to fix the issue use use both
"TARGETS" and "TARGETS_ROOTFS" variables.

Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
Cc: Vincent Stehlé <vincent.stehle@freescale.com>
Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index 197cf848bc3142ee5890ff1560ed10ce9693a37e..41c51c6b2a637f2e837b5243b7470361bcd49a62 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -419,7 +419,8 @@ TARGETS_DIRCLEAN:=$(patsubst %,%-dirclean,$(TARGETS))
 # variable for each enabled target.
 # Notice: this only works for newstyle gentargets/autotargets packages
 TARGETS_HOST_DEPS = $(sort $(filter host-%,$(foreach dep,\
-               $(addsuffix _DEPENDENCIES,$(call UPPERCASE,$(TARGETS))),\
+               $(addsuffix _DEPENDENCIES,\
+                       $(call UPPERCASE,$(TARGETS) $(TARGETS_ROOTFS))),\
                $($(dep)))))
 # Host packages can in turn have their own dependencies. Likewise find
 # all the package names listed in the HOST_<PKG>_DEPENDENCIES for each