tcpreplay: use pcap-config
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 19 Jun 2014 10:26:48 +0000 (07:26 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 19 Jun 2014 11:19:37 +0000 (13:19 +0200)
Since other libs can be pulled in by libpcap switch to using
pcap-config, it's the correct way and simpler. Fixes:
http://autobuild.buildroot.net/results/c02/c023bacd35e9ef1addeb881cd3d572f97f9b4b56/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tcpreplay/tcpreplay.mk

index 2ee224e22e4596e0260f644cd234a16028f81ffa..0f2f2e6bda2622c96116cb71758856965d97213c 100644 (file)
@@ -15,10 +15,8 @@ TCPREPLAY_CONF_ENV = \
 TCPREPLAY_CONF_OPT = --with-libpcap=$(STAGING_DIR)/usr
 TCPREPLAY_DEPENDENCIES = libpcap
 
-# libpcap may depend on symbols in libdbus-1 and libusb as well
-TCPREPLAY_LIBS = -lpcap \
-       $(if $(BR2_PACKAGE_DBUS),-ldbus-1) \
-       $(if $(BR2_PACKAGE_LIBUSB),-lusb-1.0)
+# libpcap may depend on symbols in other libs
+TCPREPLAY_LIBS = $(shell $(STAGING_DIR)/usr/bin/pcap-config --static --libs)
 TCPREPLAY_CONF_ENV += ac_cv_search_pcap_close='$(TCPREPLAY_LIBS)' \
        LIBS="$(TCPREPLAY_LIBS)"