package/nginx: remove rtsig module support
authorSamuel Martin <s.martin49@gmail.com>
Mon, 1 Dec 2014 22:04:56 +0000 (23:04 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 3 Dec 2014 12:32:21 +0000 (13:32 +0100)
rtsig module uses the deprecated sysctl syscall, which is not
implemented on some recent architecture (such as arc).

Also, rtsig module is almost considered as deprecated by some nginx
developers [1].

So, just remove this option.

Fixes:
  http://autobuild.buildroot.org/results/730/730105fc0a89b381b3b29192d07f28ef1f13cbb3/

[1] http://mailman.nginx.org/pipermail/nginx-devel/2014-November/006295.html

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/nginx/Config.in
package/nginx/nginx.mk

index ddab0caf2cadb62c48e8c36e720189bdd759fbd2..c2a6af15f5b4da79833423222e473c003364677f 100644 (file)
@@ -309,11 +309,6 @@ endif #BR2_PACKAGE_NGINX_MAIL
 
 comment "misc. modules"
 
-config BR2_PACKAGE_NGINX_RTSIG_MODULE
-       bool "ngx_rtsig_module"
-       help
-         Enable ngx_rtsig_module
-
 config BR2_PACKAGE_NGINX_SELECT_MODULE
        bool "ngx_select_module"
        help
index 55ae8442fac736c28694d2accd2116acff1eba3c..06f1312e33cb2d6f4cd8394953e43cc44344643d 100644 (file)
@@ -88,7 +88,6 @@ endif
 
 # misc. modules
 NGINX_CONF_OPTS += \
-       $(if $(BR2_PACKAGE_NGINX_RTSIG_MODULE),--with-rtsig_module) \
        $(if $(BR2_PACKAGE_NGINX_SELECT_MODULE),--with-select_module,--without-select_module) \
        $(if $(BR2_PACKAGE_NGINX_POLL_MODULE),--with-poll_module,--without-poll_module)