package/openvpn: add mbedtls support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 29 Oct 2020 17:35:56 +0000 (18:35 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 3 Nov 2020 22:22:54 +0000 (23:22 +0100)
mbedtls (former polarssl) support was dropped with commit
3380da69c5ab490e5c51dca0c4389b0da91743d0

Put it back as openvpn supports mbedtls 2.x since version 2.4.0 and
https://github.com/OpenVPN/openvpn/commit/86d8cd6860dfc74cb1a040ff8fe03140ebe7f930

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/openvpn/Config.in
package/openvpn/openvpn.mk

index 0a1675573afdc216e77b27fd5333a955c7b5cba1..3f4a617fb7c695f43b2f6068d151858f3d5c0443 100644 (file)
@@ -1,7 +1,7 @@
 config BR2_PACKAGE_OPENVPN
        bool "openvpn"
        depends on BR2_USE_MMU # fork()
-       select BR2_PACKAGE_OPENSSL
+       select BR2_PACKAGE_OPENSSL if !BR2_PACKAGE_MBEDTLS
        help
          OpenVPN is a full-featured SSL VPN solution which can
          accomodate a wide range of configurations, including road
index 4234675d9fb451b5f0b04c4cce51cf8411bafc2e..1008c47b5abb39965d3bcd63552b5c0a665f3e7e 100644 (file)
@@ -7,12 +7,11 @@
 OPENVPN_VERSION = 2.4.9
 OPENVPN_SOURCE = openvpn-$(OPENVPN_VERSION).tar.xz
 OPENVPN_SITE = http://swupdate.openvpn.net/community/releases
-OPENVPN_DEPENDENCIES = host-pkgconf openssl
+OPENVPN_DEPENDENCIES = host-pkgconf
 OPENVPN_LICENSE = GPL-2.0
 OPENVPN_LICENSE_FILES = COPYRIGHT.GPL
 OPENVPN_CONF_OPTS = \
        --enable-iproute2 \
-       --with-crypto-library=openssl \
        $(if $(BR2_STATIC_LIBS),--disable-plugins)
 OPENVPN_CONF_ENV = IFCONFIG=/sbin/ifconfig \
        NETSTAT=/bin/netstat \
@@ -51,6 +50,14 @@ else
 OPENVPN_CONF_OPTS += --disable-plugin-auth-pam
 endif
 
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+OPENVPN_DEPENDENCIES += openssl
+OPENVPN_CONF_OPTS += --with-crypto-library=openssl
+else ifeq ($(BR2_PACKAGE_MBEDTLS),y)
+OPENVPN_DEPENDENCIES += mbedtls
+OPENVPN_CONF_OPTS += --with-crypto-library=mbedtls
+endif
+
 ifeq ($(BR2_PACKAGE_PKCS11_HELPER),y)
 OPENVPN_DEPENDENCIES += pkcs11-helper
 OPENVPN_CONF_OPTS += --enable-pkcs11