python-six: add host variant
authorJulien Floret <julien.floret@6wind.com>
Wed, 13 Sep 2017 13:20:55 +0000 (15:20 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 24 Sep 2017 11:46:20 +0000 (13:46 +0200)
While currently there is no in-tree Buildroot package which depends on
host-python-six, it can be needed to build external packages.

Signed-off-by: Julien Floret <julien.floret@6wind.com>
Tested-by: Carlos Santos <casantos@datacom.ind.br>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/Config.in.host
package/python-six/Config.in.host [new file with mode: 0644]
package/python-six/python-six.mk

index 9e05ec659c3da672ceb92f1a9aea18e27da93d71..679fe22a520b42b9da3f012d3029550afc406e6e 100644 (file)
@@ -38,6 +38,7 @@ menu "Host utilities"
        source "package/pru-software-support/Config.in.host"
        source "package/pwgen/Config.in.host"
        source "package/python-lxml/Config.in.host"
+       source "package/python-six/Config.in.host"
        source "package/qemu/Config.in.host"
        source "package/raspberrypi-usbboot/Config.in.host"
        source "package/rauc/Config.in.host"
diff --git a/package/python-six/Config.in.host b/package/python-six/Config.in.host
new file mode 100644 (file)
index 0000000..1d37e76
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_HOST_PYTHON_SIX
+       bool "host python-six"
+       help
+         Six is a Python 2 and 3 compatibility library. It provides
+         utility functions for smoothing over the differences between
+         the Python versions with the goal of writing Python code that
+         is compatible on both Python versions.
+
+         http://pythonhosted.org/six
index 0edefe346fdb646dca09439a718c425ce2789e48..850f9340d322e03666a0430d039e10512cbe106c 100644 (file)
@@ -12,3 +12,4 @@ PYTHON_SIX_LICENSE = MIT
 PYTHON_SIX_LICENSE_FILES = LICENSE
 
 $(eval $(python-package))
+$(eval $(host-python-package))