boinc: replace systemd script
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 28 Apr 2018 14:24:17 +0000 (16:24 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 28 Apr 2018 16:59:01 +0000 (18:59 +0200)
Remove buildroot systemd script to use the script embedded by boinc
since version 7.9.1.
Set BOINC_USERS to be able to use this script

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/boinc/boinc-client.service [deleted file]
package/boinc/boinc.mk

diff --git a/package/boinc/boinc-client.service b/package/boinc/boinc-client.service
deleted file mode 100644 (file)
index 9de940e..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=BOINC client
-After=network.target
-
-[Service]
-ExecStart=/usr/bin/boinc_client
-Restart=always
-
-[Install]
-WantedBy=multi-user.target
index 257987291c9917426a7d29bff6424a02f0f6aec0..04aacc2c3d4089e7e0d904af58cef9195a00f581 100644 (file)
@@ -44,14 +44,16 @@ endef
 
 BOINC_POST_INSTALL_TARGET_HOOKS += BOINC_REMOVE_UNNEEDED_FILE
 
+define BOINC_USERS
+       boinc -1 boinc -1 * /var/lib/boinc - BOINC user
+endef
+
 define BOINC_INSTALL_INIT_SYSV
        $(INSTALL) -D -m 0755 package/boinc/S99boinc-client \
                $(TARGET_DIR)/etc/init.d/S99boinc-client
 endef
 
 define BOINC_INSTALL_INIT_SYSTEMD
-       $(INSTALL) -D -m 644 package/boinc/boinc-client.service \
-               $(TARGET_DIR)/usr/lib/systemd/system/boinc-client.service
        mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
        ln -sf ../../../../usr/lib/systemd/system/boinc-client.service \
                $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/boinc-client.service