uboot: revert "uboot: use local libfdt.h"
authorThomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Mon, 19 Feb 2018 15:56:32 +0000 (16:56 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 25 Feb 2018 21:40:22 +0000 (22:40 +0100)
This reverts commit 3a6573ccee2624de0c604abf2c7df6704a4cf566.

It is no longer necessary after solving the problem differently.

Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
boot/uboot/uboot.mk

index 977f44cad8adf3771d5998ea975d8f97fcc0bfdd..c7cd7391501343bf361f040a4b8725509b6cb132 100644 (file)
@@ -188,13 +188,6 @@ define UBOOT_APPLY_LOCAL_PATCHES
 endef
 UBOOT_POST_PATCH_HOOKS += UBOOT_APPLY_LOCAL_PATCHES
 
-# Bug: https://patchwork.ozlabs.org/patch/833760/
-define UBOOT_FIX_LIBFDT_SYSTEM_PATH
-       [ ! -e $(@D)/tools/fdtgrep.c ] || \
-       $(SED) 's%<../include/libfdt.h>%"../include/libfdt.h"%' $(@D)/tools/fdtgrep.c
-endef
-UBOOT_POST_PATCH_HOOKS += UBOOT_FIX_LIBFDT_SYSTEM_PATH
-
 ifeq ($(BR2_TARGET_UBOOT_BUILD_SYSTEM_LEGACY),y)
 define UBOOT_CONFIGURE_CMDS
        $(TARGET_CONFIGURE_OPTS)        \