package: don't use .xz format for github
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 9 Sep 2013 09:38:15 +0000 (11:38 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 9 Sep 2013 09:40:44 +0000 (11:40 +0200)
Fixes http://autobuild.buildroot.net/results/955/955ed1af28f6ff9912adddc0342d1f3ca65e5b4d/

Commit 62146ea3ad7 (change package tarball compression to xz whenever possible)
changed a number of packages to use .xz format tarballs. Unfortunately this
doesn't work for packages from github, as it delivers gzip compressed tarballs
even when a .xz is requested.

Fix it by reverting this change for the packages using github.

Reported-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/cpuload/cpuload.mk
package/fb-test-app/fb-test-app.mk
package/input-event-daemon/input-event-daemon.mk

index c8d1d0ceea5e7bc9f3451d1e31b953e78d85696f..e0b8ccfb16f92c2d3b48b528463d19297ea7f7e1 100644 (file)
@@ -5,10 +5,8 @@
 ################################################################################
 
 CPULOAD_VERSION = v0.3
-CPULOAD_SOURCE = cpuload-$(CPULOAD_VERSION).tar.xz
 CPULOAD_SITE = http://github.com/kelvincheung/cpuload/tarball/$(CPULOAD_VERSION)
 CPULOAD_LICENSE = GPLv2
 CPULOAD_LICENSE_FILES = COPYING
 
-
 $(eval $(autotools-package))
index 5b95c29fabeeb2f8775c24905b902dc58dfbf9ff..a2183e0080cbff250f8a19281445a04827e98cd3 100644 (file)
@@ -5,7 +5,6 @@
 ################################################################################
 
 FB_TEST_APP_VERSION = v1.0.0
-FB_TEST_APP_SOURCE = fb-test-app-$(FB_TEST_APP_VERSION).tar.xz
 FB_TEST_APP_SITE = http://github.com/prpplague/fb-test-app/tarball/$(FB_TEST_APP_VERSION)
 FB_TEST_APP_LICENSE = GPLv2
 FB_TEST_APP_LICENSE_FILES = COPYING
index cbcc2df79205161667e3acba33a8098c60e75f03..762d3c2b5ce1515f9abcb72993c78144b960918b 100644 (file)
@@ -5,7 +5,6 @@
 ################################################################################
 
 INPUT_EVENT_DAEMON_VERSION = v0.1.3
-INPUT_EVENT_DAEMON_SOURCE = input-event-daemon-$(INPUT_EVENT_DAEMON_VERSION).tar.xz
 INPUT_EVENT_DAEMON_SITE = http://github.com/gandro/input-event-daemon/tarball/$(INPUT_EVENT_DAEMON_VERSION)
 INPUT_EVENT_DAEMON_LICENSE = input-event-daemon license
 INPUT_EVENT_DAEMON_LICENSE_FILES = README