bind: disable parallel build
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 20 Feb 2011 13:35:23 +0000 (14:35 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 20 Feb 2011 13:36:52 +0000 (14:36 +0100)
The build system of bind seems to have issues with (highly) parallel
builds, breaking the build with errors like:

libtool: link: `nothreads/condition.lo' is not a valid libtool object

So disable parallel builds.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/bind/bind.mk

index f402ad127ef910a1f6b9bdcb21445a1a612e5d2d..ff0ec04d2cb917405363be2e55d457e2edbf97b5 100644 (file)
@@ -11,6 +11,7 @@ BIND_TARGET_SBINS += named-compilezone rndc rndc-confgen
 BIND_TARGET_SBINS += dnssec-keygen dnssec-signzone
 BIND_TARGET_BINS = dig host nslookup nsupdate
 BIND_TARGET_LIBS = libbind9.* libdns.* libisccc.* libisccfg.* libisc.* liblwres.*
+BIND_MAKE = $(MAKE1)
 BIND_CONF_ENV =        BUILD_CC="$(TARGET_CC)" \
                BUILD_CFLAGS="$(TARGET_CFLAGS)"
 BIND_CONF_OPT =        \