libvorbis: remove BR2_PACKAGE_LIBVORBIS_HEADERS
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 16 Jun 2008 11:34:29 +0000 (11:34 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 16 Jun 2008 11:34:29 +0000 (11:34 -0000)
We don't need per-package header install options now that we have
BR2_HAVE_DEVFILES (they are in fact useless as the files will get
overwritten/deleted anyway).

package/libvorbis/Config.in
package/libvorbis/libvorbis.mk

index 4d590744892954a4ad5f009020d2113f8ce764b9..e9d8fc7e6d195cb2f7f6e526f973d1693e761b38 100644 (file)
@@ -15,14 +15,6 @@ config BR2_PACKAGE_LIBVORBIS
          performance than MPEG-1/2 audio layer 3, MPEG-4 audio (TwinVQ),
          WMA and PAC.
 
-
-config BR2_PACKAGE_LIBVORBIS_HEADERS
-       bool "libvorbis target headers"
-       default n
-       depends on BR2_PACKAGE_LIBVORBIS
-       help
-         Add target headers for the Vorbis open source audio decoder
-
 config BR2_PACKAGE_LIBVORBIS_TREMOR
        bool "libvorbis integer implementation"
        default y if BR2_arm || BR2_avr32
index b6358778a19eeb96c9c66a76b5d0ccd72a1eff1e..3e496d9388e4e25f7b619d39e788db3e942f52d3 100644 (file)
@@ -47,15 +47,6 @@ $(TARGET_DIR)/usr/lib/libvorbis.so: $(LIBVORBIS_DIR)/.libs
        $(MAKE) prefix=$(TARGET_DIR)/usr -C $(LIBVORBIS_DIR) install
        touch $@
 
-$(TARGET_DIR)/usr/lib/libvorbis.a: $(TARGET_DIR)/usr/lib/libvorbis.so
-       cp -dpf $(LIBVORBIS_DIR)/lib/libvorbis.a $(TARGET_DIR)/usr/lib/
-       touch $@
-
-libvorbis-header: $(TARGET_DIR)/usr/lib/libvorbis.a
-       mkdir -p $(TARGET_DIR)/usr/include/vorbis
-       cp -dpf $(LIBVORBIS_DIR)/include/vorbis/*.h \
-               $(TARGET_DIR)/usr/include/vorbis
-
 libvorbis: uclibc pkgconfig libogg $(TARGET_DIR)/usr/lib/libvorbis.so
 
 libvorbis-source: $(DL_DIR)/$(LIBVORBIS_SOURCE)
@@ -124,11 +115,6 @@ $(TARGET_DIR)/usr/lib/tremor.a: $(TARGET_DIR)/usr/lib/tremor.so
        cp -dpf $(TREMOR_DIR)/lib/tremor.a $(TARGET_DIR)/usr/lib/
        touch $@
 
-tremor-header: $(TARGET_DIR)/usr/lib/tremor.a
-       mkdir -p $(TARGET_DIR)/usr/include/vorbis
-       cp -dpf $(TREMOR_DIR)/include/vorbis/*.h \
-               $(TARGET_DIR)/usr/include/vorbis
-
 tremor: uclibc pkgconfig libogg $(TARGET_DIR)/usr/lib/tremor.so
 
 tremor-source: $(DL_DIR)/$(TREMOR_SOURCE)
@@ -152,7 +138,3 @@ TARGETS+=tremor
 endif
 TARGETS+=libvorbis
 endif
-
-ifeq ($(strip $(BR2_PACKAGE_LIBVORBIS_HEADERS)),y)
-TARGETS+=libvorbis-header
-endif