util-linux: use configure option instead of patching makefile
authorPeter Seiderer <ps.report@gmx.net>
Tue, 21 Oct 2014 19:32:36 +0000 (21:32 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Oct 2014 19:08:41 +0000 (21:08 +0200)
Use --disable-all-programs configure option instead of sed base
patching of Makefile.am in case no util-linux binaries are selected.

Suggested by Thomas Petazzoni ([1]).

With this patch applied the following libs are no longer build by default:

util-linux-2.25.1/.libs/libfdisk.a
util-linux-2.25.1/.libs/libsmartcols.a
util-linux-2.25.1/.libs/libsmartcols.so.1.1.0

[1] http://lists.busybox.net/pipermail/buildroot/2014-October/109818.html

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tested-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/util-linux/util-linux.mk

index ebbab615e87ab9228e13b74199f232eb3da4133d..1d52b5048f3996a94f452e4a93d39ffb953aea41 100644 (file)
@@ -100,13 +100,7 @@ HOST_UTIL_LINUX_CONF_OPTS += \
 # Avoid building the tools if they are disabled since we can't install on
 # a per-directory basis.
 ifeq ($(BR2_PACKAGE_UTIL_LINUX_BINARIES),)
-define UTIL_LINUX_DISABLE_TOOLS
-       $(SED) '/schedutils/d' -e '/text-utils/d' -e '/term-utils/d' \
-               -e '/login-utils/d' -e '/mount-deprecated/d' \
-               -e '/sys-utils/d' -e '/misc-utils/d' -e '/disk-utils/d' \
-               -e '/fdisks/d' $(@D)/Makefile.am
-endef
-UTIL_LINUX_PRE_PATCH_HOOKS += UTIL_LINUX_DISABLE_TOOLS
+UTIL_LINUX_CONF_OPTS += --disable-all-programs
 endif
 
 # Install PAM configuration files