berkeleydb: fix build of shared libraries
authorLuca Ceresoli <luca@lucaceresoli.net>
Mon, 20 Jun 2011 15:59:55 +0000 (17:59 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 21 Jun 2011 11:27:10 +0000 (13:27 +0200)
009d8fceab4 and 0a5e5534cbf8 moved the --enable-static configure flag
from package files to the default _CONFIGURE_CMDS in
package/Makefile.autotools.in.
This broke Autotools packages that override _CONFIGURE_CMDS.

Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/berkeleydb/berkeleydb.mk

index 1bac745b291acc32d6afb6898a729ee536ced709..e80f66f60ffa6c494cbb03c77d11c493463f73b1 100644 (file)
@@ -38,6 +38,7 @@ define BERKELEYDB_CONFIGURE_CMDS
                --disable-rpc \
                --disable-tcl \
                --disable-compat185 \
+               $(SHARED_STATIC_LIBS_OPTS) \
                --with-pic \
        )
        $(SED) 's/\.lo/.o/g' $(@D)/build_unix/Makefile