tor: link with libatomic when needed
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 14 Jun 2018 18:23:19 +0000 (20:23 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 17 Jun 2018 20:51:13 +0000 (22:51 +0200)
The following error occurs on architectures required to use gcc
libatomic for atomic intrinsics:

sparc-buildroot-linux-uclibc/sysroot/lib/libatomic.so.1: error adding symbols: DSO missing from command line

This is for example the case on sparcv8 32 bit.

Fixes:

 http://autobuild.buildroot.net/results/0f7107d0b703223f567c6749722bc82c81a04d54

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Thomas: use LIBS instead of LDFLAGS.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/tor/tor.mk

index 39006e7caf78a5c7daa4076ce9e5a553112b8bfd..fe22633bf627191fe51d0fcb874cf8fbed75a878 100644 (file)
@@ -47,6 +47,10 @@ endif
 # uses gnu extensions
 TOR_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99'
 
+ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
+TOR_CONF_ENV += LIBS=-latomic
+endif
+
 define TOR_INSTALL_CONF
        $(INSTALL) -D -m 644 $(@D)/src/config/torrc.minimal \
                $(TARGET_DIR)/etc/tor/torrc