sqlcipher: specify tclConfig.sh directory
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 14 Oct 2015 21:41:57 +0000 (18:41 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 14 Oct 2015 21:49:23 +0000 (23:49 +0200)
Otherwise it will search around, and if the host has it then it breaks.
Fixes:
http://autobuild.buildroot.net/results/057/0572a9a1f69ee214efb10863f5d2852b25bf4f54/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sqlcipher/sqlcipher.mk

index 9693eb947fed6b362dfbfd6a8ee6da9a2ecfd03a..fadec2207fdf5da39f1a1a2e501f6361208c8a77 100644 (file)
@@ -14,7 +14,8 @@ SQLCIPHER_CONF_ENV = \
        TCLSH_CMD=$(HOST_DIR)/usr/bin/tclsh$(TCL_VERSION_MAJOR)
 
 SQLCIPHER_CONF_OPTS = \
-       --enable-threadsafe
+       --enable-threadsafe \
+       --with-tcl=$(HOST_DIR)/usr/lib
 
 SQLCIPHER_CFLAGS += -DSQLITE_HAS_CODEC # Required according to the README
 SQLCIPHER_CONF_ENV += LIBS="-lcrypto -lz"