Makefile: help: add package-specific targets
authorArnout Vandecappelle <arnout@mind.be>
Sat, 21 Mar 2015 19:49:47 +0000 (20:49 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 4 Apr 2015 13:17:48 +0000 (15:17 +0200)
The documentation of the package-specific targets is heavily inspired by
the earlier patch by Thomas Petazzoni [1], but the <pkg>-install*
targets were left out since they're not useful for the developer IMHO.

The *-menuconfig target's help text is moved to the package-specific
targets.

[1] http://patchwork.ozlabs.org/patch/433692

[Thomas: remove double <pkg>-graph-depends help.]

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index 32a18ff4d936f881de7f5bb82d71f6fbff5902ae..8d097250146ce374920a6acbc15cac20c591e02c 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -873,6 +873,20 @@ help:
        @echo '  randpackageconfig      - New config with random answer to package options'
        @echo '  allyespackageconfig    - New config where pkg options are accepted with yes'
        @echo '  allnopackageconfig     - New config where package options are answered with no'
+       @echo
+       @echo 'Package-specific:'
+       @echo '  <pkg>                  - Build and install <pkg> and all its dependencies'
+       @echo '  <pkg>-source           - Only download the source files for <pkg>'
+       @echo '  <pkg>-extract          - Extract <pkg> sources'
+       @echo '  <pkg>-patch            - Apply patches to <pkg>'
+       @echo '  <pkg>-depends          - Build <pkg>'\''s dependencies'
+       @echo '  <pkg>-configure        - Build <pkg> up to the configure step'
+       @echo '  <pkg>-build            - Build <pkg> up to the build step'
+       @echo '  <pkg>-graph-depends    - Generate a graph of <pkg>'\''s dependencies'
+       @echo '  <pkg>-dirclean         - Remove <pkg> build directory'
+       @echo '  <pkg>-reconfigure      - Restart the build from the configure step'
+       @echo '  <pkg>-rebuild          - Restart the build from the build step'
+       @echo '  <pkg>-legal-info       - Generate license information for <pkg>'
 ifeq ($(BR2_PACKAGE_BUSYBOX),y)
        @echo '  busybox-menuconfig     - Run BusyBox menuconfig'
 endif