pkg-stats: add new column with check-package warnings
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 8 Apr 2017 19:35:33 +0000 (21:35 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 8 Apr 2017 19:35:33 +0000 (21:35 +0200)
This allows the page at http://autobuild.buildroot.net/stats/ to show
how many warnings returned by check-package affect each package.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
support/scripts/pkg-stats

index 421fa5cf5d0ff6d02730edeb888f697abc661847..28706628e907f5ae463b638ba0eac7e34c9144cf 100755 (executable)
@@ -68,6 +68,7 @@ td.lotsofpatches {
 <td class=\"centered\">License</td>
 <td class=\"centered\">License files</td>
 <td class=\"centered\">Hash file</td>
+<td class=\"centered\">Warnings</td>
 </tr>
 "
 
@@ -323,6 +324,14 @@ for i in $(find boot/ linux/ package/ -name '*.mk' | sort) ; do
        echo "<td class=\"centered correct\">Yes</td>"
     fi
 
+    file_list=$(find ${package_dir} -name '*.mk' -o -name '*.in*' -o -name '*.hash')
+    nwarnings=$(./support/scripts/check-package ${file_list} 2>&1 | sed '/\([0-9]*\) warnings generated/!d; s//\1/')
+    if [ ${nwarnings} -eq 0 ] ; then
+       echo "<td class=\"centered correct\">${nwarnings}</td>"
+    else
+       echo "<td class=\"centered wrong\">${nwarnings}</td>"
+    fi
+
     echo "</tr>"
 
 done