systemd: Replace busybox' binaries only if applicable
authorPaul Cercueil <paul@crapouillou.net>
Tue, 17 Dec 2013 01:14:54 +0000 (02:14 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 17 Dec 2013 16:01:53 +0000 (17:01 +0100)
Previously, the package would overwrite busybox' binaries even
if Busybox was set in the config as the default init system.

Signed-Off-By: Paul Cercueil <paul@crapouillou.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/systemd/systemd.mk

index 4e4955e2bb8565db5cd124d4c56a7daa3f146724..a5dc8e59140e49719837206a0c01493671a8c050 100644 (file)
@@ -54,6 +54,7 @@ endif
 SYSTEMD_MAKE_OPT += LIBS=-lrt
 SYSTEMD_MAKE_OPT += LDFLAGS+=-ldl
 
+ifeq ($(BR2_INIT_SYSTEMD),y)
 define SYSTEMD_INSTALL_INIT_HOOK
        ln -fs ../usr/lib/systemd/systemd $(TARGET_DIR)/sbin/init
        ln -fs ../usr/bin/systemctl $(TARGET_DIR)/sbin/halt
@@ -62,6 +63,9 @@ define SYSTEMD_INSTALL_INIT_HOOK
 
        ln -fs ../../../usr/lib/systemd/system/multi-user.target $(TARGET_DIR)/etc/systemd/system/default.target
 endef
+SYSTEMD_POST_INSTALL_TARGET_HOOKS += \
+       SYSTEMD_INSTALL_INIT_HOOK
+endif
 
 define SYSTEMD_INSTALL_TTY_HOOK
        rm -f $(TARGET_DIR)/etc/systemd/system/getty.target.wants/getty@tty1.service
@@ -69,7 +73,6 @@ define SYSTEMD_INSTALL_TTY_HOOK
 endef
 
 SYSTEMD_POST_INSTALL_TARGET_HOOKS += \
-       SYSTEMD_INSTALL_INIT_HOOK \
        SYSTEMD_INSTALL_TTY_HOOK \
 
 $(eval $(autotools-package))