only run ldconfig if ld.so.conf exists
authorMike Frysinger <vapier@gentoo.org>
Thu, 4 Aug 2005 22:17:36 +0000 (22:17 -0000)
committerMike Frysinger <vapier@gentoo.org>
Thu, 4 Aug 2005 22:17:36 +0000 (22:17 -0000)
target/tar/tarroot.mk

index 2ac07cddc7ce1e74552d64a84775d7002252ab27..526f156b6a4fc52fccb215c54c81fce2c841af1c 100644 (file)
@@ -10,7 +10,9 @@ tarroot: host-fakeroot makedevs
        -@find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIP) 2>/dev/null || true;
        @rm -rf $(TARGET_DIR)/usr/man
        @rm -rf $(TARGET_DIR)/usr/info
-       /sbin/ldconfig -r $(TARGET_DIR)
+       test -e "$(TARGET_DIR)/etc/ld.so.conf" \
+               && /sbin/ldconfig -r $(TARGET_DIR) \
+               || true
        # Use fakeroot to pretend all target binaries are owned by root
        $(STAGING_DIR)/usr/bin/fakeroot \
                -i $(STAGING_DIR)/fakeroot.env \