dosfstools: fix compilation with musl libc
authorMaarten ter Huurne <maarten@treewalker.org>
Thu, 11 Sep 2014 05:16:10 +0000 (07:16 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 28 Sep 2014 20:03:39 +0000 (22:03 +0200)
The Makefile of dosfstools passes -D_GNU_SOURCE to get access to
non-standard definitions such as 'loff_t'. But this flag gets dropped
by the CFLAGS override, so explicitly add it.

[Peter: reword commit message]
Signed-off-by: Maarten ter Huurne <maarten@treewalker.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/dosfstools/dosfstools.mk

index a6b83d0d1e15d4886a12a09837665961a6cfebd6..a9d8392c8c9b198e2854d9ede2c7a4ecde52eb70 100644 (file)
@@ -13,6 +13,8 @@ DOSFSTOOLS_LICENSE_FILES = COPYING
 # Avoid target dosfstools dependencies, no host-libiconv
 HOST_DOSFSTOOLS_DEPENDENCIES =
 
+DOSFSTOOLS_CFLAGS = $(TARGET_CFLAGS) -D_GNU_SOURCE
+
 ifneq ($(BR2_ENABLE_LOCALE),y)
 DOSFSTOOLS_DEPENDENCIES += libiconv
 DOSFSTOOLS_LDLIBS += -liconv
@@ -23,7 +25,8 @@ FSCK_FAT_BINARY = fsck.fat
 MKFS_FAT_BINARY = mkfs.fat
 
 define DOSFSTOOLS_BUILD_CMDS
-       $(MAKE) $(TARGET_CONFIGURE_OPTS) LDLIBS="$(DOSFSTOOLS_LDLIBS)" -C $(@D)
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(DOSFSTOOLS_CFLAGS)" LDLIBS="$(DOSFSTOOLS_LDLIBS)" -C $(@D)
 endef
 
 DOSFSTOOLS_INSTALL_BIN_FILES_$(BR2_PACKAGE_DOSFSTOOLS_FATLABEL)+=$(FATLABEL_BINARY)