patch: needs toolchain with wchar
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 17 Dec 2010 15:29:09 +0000 (12:29 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 22 Dec 2010 21:56:55 +0000 (22:56 +0100)
* Patch needs a toolchain with WCHAR support
* Use real upstream gnu mirror

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/patch/Config.in
package/patch/patch.mk

index 5a80ea561f8a7182eb2faabec09d985f5e1b7493..dd6d51c17b47584f651546ff4aa6bb77d25343b3 100644 (file)
@@ -1,7 +1,11 @@
 config BR2_PACKAGE_PATCH
        bool "patch"
+       depends on BR2_USE_WCHAR
        help
          Take patch files (containing difference listings) and apply them
          to original files, producing patched versions.
 
          http://www.gnu.org/software/patch/
+
+comment "patch needs a toolchain with WCHAR support"
+       depends on !BR2_USE_WCHAR
index 80d9db1883796a29944561db087932418243a537..5c46c779c003a537eaca3ecdab833be6665d1497 100644 (file)
@@ -3,8 +3,8 @@
 # patch
 #
 #############################################################
-PATCH_VERSION:=2.6
-PATCH_SOURCE:=patch_$(PATCH_VERSION).orig.tar.gz
-PATCH_SITE:=$(BR2_DEBIAN_MIRROR)/debian/pool/main/p/patch
+
+PATCH_VERSION = 2.6
+PATCH_SITE = $(BR2_GNU_MIRROR)/patch
 
 $(eval $(call AUTOTARGETS,package,patch))