buildroot: get rid of s390 support
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 12 Jan 2009 14:36:14 +0000 (14:36 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 12 Jan 2009 14:36:14 +0000 (14:36 -0000)
As discussed on the list. It isn't supported by uclibc, so I strongly doubt
anyone has been using it.

.defconfig
package/Makefile.in
package/liboil/liboil.mk
package/multimedia/gstreamer/gstreamer.mk
target/Config.in.arch
toolchain/kernel-headers/kernel-headers.mk

index 7da0e441806795834fb7bc41be6c704dffff9caa..77ab11aeddafd1f8259db234255bc0095bc8e7f4 100644 (file)
@@ -15,7 +15,6 @@ BR2_i386=y
 # BR2_mipsel is not set
 # BR2_nios2 is not set
 # BR2_powerpc is not set
-# BR2_s390 is not set
 # BR2_sh is not set
 # BR2_sh64 is not set
 # BR2_sparc is not set
index 186329cf1299f9cabbb147aa29ac077fabf25690..f11b396a1c40fa7d9e2d277f13dddab81ddc6d0e 100644 (file)
@@ -298,9 +298,6 @@ endif
 ifeq ($(BR2_m68k),y)
 BR2_AC_CV_TRAP_CHECK=ac_cv_lbl_unaligned_fail=no
 endif
-ifeq ($(BR2_s390),y)
-BR2_AC_CV_TRAP_CHECK=ac_cv_lbl_unaligned_fail=no
-endif
 ifeq ($(BR2_powerpc)$(BR2_ENDIAN),yBIG)
 BR2_AC_CV_TRAP_CHECK=ac_cv_lbl_unaligned_fail=no
 endif
index 6e80ed60e1fc35e6adcbad7107f8b8454a26e378..0d1ec8291278f56807a0575e9c3ca6be9586f73f 100644 (file)
@@ -22,9 +22,6 @@ endif
 ifeq ($(BR2_nios2),y)
 LIBOIL_CONF_ENV = as_cv_unaligned_access=no
 endif
-ifeq ($(BR2_s390),y)
-LIBOIL_CONF_ENV = as_cv_unaligned_access=yes
-endif
 ifeq ($(BR2_x86_64),y)
 LIBOIL_CONF_ENV = as_cv_unaligned_access=yes
 endif
index ba66b83ba4c2bb8cca9437165f61c8dcebaa8dee..3d4033e199fc75c30a7f373a46cc6b04bec196fc 100644 (file)
@@ -17,9 +17,6 @@ endif
 ifeq ($(BR2_nios2),y)
 GSTREAMER_CONF_ENV = as_cv_unaligned_access=no
 endif
-ifeq ($(BR2_s390),y)
-GSTREAMER_CONF_ENV = as_cv_unaligned_access=yes
-endif
 
 GSTREAMER_CONF_OPT = \
                $(DISABLE_NLS) \
index 4c09d4211c9b230d9841cbb87b6198e876b200b7..ccadca8203c72cd2cf1c93369e9f990b8496a92b 100644 (file)
@@ -30,8 +30,6 @@ config BR2_nios2
        bool "nios2"
 config BR2_powerpc
        bool "powerpc"
-config BR2_s390
-       bool "s390"
 config BR2_sh
        bool "superh"
 config BR2_sh64
@@ -308,25 +306,6 @@ config BR2_alpha_21264a
        bool "21264a"
 endchoice
 
-choice
-       prompt "Target Architecture Variant"
-       depends on BR2_s390
-       default BR2_s390_g5
-       help
-         Specific CPU variant to use
-
-config BR2_s390_g5
-       bool "g5"
-config BR2_s390_g6
-       bool "g6"
-config BR2_s390_z900
-       bool "z900"
-config BR2_s390_z990
-       bool "z990"
-config BR2_s390_z9_109
-       bool "z9_109"
-endchoice
-
 choice
        prompt "Target Architecture Variant"
        depends on BR2_sparc
@@ -497,8 +476,6 @@ config BR2_ARCH
        default "mipsel"        if BR2_mipsel
        default "nios2"         if BR2_nios2
        default "powerpc"       if BR2_powerpc
-       default "s390"          if BR2_s390
-       default "s390"          if BR2_s390x
        default "sh2a_nofpueb"  if BR2_sh2a_nofpueb
        default "sh2eb"         if BR2_sh2eb
        default "sh3"           if BR2_sh3
@@ -646,11 +623,6 @@ config BR2_GCC_TARGET_TUNE
        default ultrasparc      if BR2_sparc_ultrasparc || BR2_sparc64_ultrasparc
        default ultrasparc3     if BR2_sparc_ultrasparc3 || BR2_sparc64_ultrasparc3
        default niagara         if BR2_sparc_niagara || BR2_sparc64_niagara
-       default g5              if BR2_s390_g5
-       default g6              if BR2_s390_g6
-       default z900            if BR2_s390_z900
-       default z990            if BR2_s390_z990
-       default z9-109          if BR2_s390_z9_109
 
 config BR2_GCC_TARGET_ARCH
        string
@@ -690,11 +662,6 @@ config BR2_GCC_TARGET_ARCH
        default 68030           if BR2_m68k_68030
        default 68040           if BR2_m68k_68040
        default 68060           if BR2_m68k_68060
-       default g5              if BR2_s390_g5
-       default g6              if BR2_s390_g6
-       default z900            if BR2_s390_z900
-       default z990            if BR2_s390_z990
-       default z9-109          if BR2_s390_z9_109
 
 config BR2_GCC_TARGET_ABI
        string
index fc8acda051e9188fb21a030588a95b128402312a..6aedc323ca6a8ea6bbe3cb5a9d51aa8030ef90de 100644 (file)
@@ -17,7 +17,7 @@ LINUX_HEADERS_UNPACK_DIR:=$(TOOL_BUILD_DIR)/linux-libc-headers-null
 KERNEL_ARCH:=$(shell $(SHELL) -c "echo \"$(ARCH)\" | sed -e \"s/-.*//\" \
        -e s/i.86/i386/ -e s/sun4u/sparc64/ \
        -e s/arm.*/arm/ -e s/sa110/arm/ \
-       -e s/s390x/s390/ -e s/parisc64/parisc/ \
+       -e s/parisc64/parisc/ \
        -e s/powerpc64/powerpc/ \
        -e s/ppc.*/powerpc/ -e s/mips.*/mips/ \
        -e s/sh2.*/sh/ -e s/sh3.*/sh/ -e s/sh4.*/sh/ \