php: fix CFLAGS handling
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 2 Jan 2011 11:28:35 +0000 (12:28 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 2 Jan 2011 21:53:16 +0000 (22:53 +0100)
The shell doesn't understand += assignments. Fixes a build issue with
sqlite extension and !largefile (and possibly with ext toolchains as well).

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/php/php.mk

index 36b105dbfa08958130285c0f816ee83cd95b9131..aa99d233b32a9e68fdb0c74ddc73b187c6f0dafd 100644 (file)
@@ -19,6 +19,8 @@ PHP_CONF_OPT =  --mandir=/usr/share/man \
                --with-config-file-path=/etc \
                --localstatedir=/var \
 
+PHP_CFLAGS = $(TARGET_CFLAGS)
+
 ifneq ($(BR2_PACKAGE_PHP_CLI),y)
        PHP_CONF_OPT += --disable-cli
 else
@@ -142,7 +144,7 @@ endif
 ifeq ($(BR2_PACKAGE_PHP_EXT_SQLITE),y)
        PHP_CONF_OPT += --with-sqlite
 ifneq ($(BR2_LARGEFILE),y)
-       PHP_CONF_ENV += CFLAGS+=" -DSQLITE_DISABLE_LFS"
+       PHP_CFLAGS += -DSQLITE_DISABLE_LFS
 endif
 ifeq ($(BR2_PACKAGE_PHP_EXT_SQLITE_UTF8),y)
        PHP_CONF_OPT += --enable-sqlite-utf8
@@ -159,9 +161,9 @@ ifeq ($(BR2_PACKAGE_PHP_EXT_PDO_SQLITE_EXTERNAL),y)
 else
        PHP_CONF_OPT += --with-pdo-sqlite
 endif
-       PHP_CONF_ENV += CFLAGS+=" -DSQLITE_OMIT_LOAD_EXTENSION"
+       PHP_CFLAGS += -DSQLITE_OMIT_LOAD_EXTENSION
 ifneq ($(BR2_LARGEFILE),y)
-       PHP_CONF_ENV += CFLAGS+=" -DSQLITE_DISABLE_LFS"
+       PHP_CFLAGS += -DSQLITE_DISABLE_LFS
 endif
 endif
 ifeq ($(BR2_PACKAGE_PHP_EXT_PDO_MYSQL),y)
@@ -192,4 +194,6 @@ define PHP_UNINSTALL_TARGET_CMDS
        rm -f $(TARGET_DIR)/usr/bin/php*
 endef
 
+PHP_CONF_ENV += CFLAGS="$(PHP_CFLAGS)"
+
 $(eval $(call AUTOTARGETS,package,php))