directfb: bump version
authorSven Neumann <s.neumann@raumfeld.com>
Tue, 23 Jun 2009 11:47:14 +0000 (13:47 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 23 Jun 2009 11:47:14 +0000 (13:47 +0200)
Closes #379

update DirectFB to version 1.4.0

A new stable version of DirectFB has been released upstream,
http://directfb.org/index.php?path=Main%2FNews&entry=2009-06-04-1.niels

Attached patch updates the DirectFB package and introduces a BR2
configuration option for the RGB16 dithering feature that is new in
DirectFB 1.4.0.

Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/directfb/Config.in
package/directfb/directfb.mk

index 5a5db46d48d6ed946654af59d2968ce0a82aca93..f24b7a11c52bda328dbd39ea98ec2baf27c3736b 100644 (file)
@@ -66,12 +66,6 @@ config BR2_PACKAGE_DIRECTFB_SERIALMOUSE
        default y
        depends on BR2_PACKAGE_DIRECTFB
 
-config BR2_PACKAGE_DIRECTFB_PNG
-       bool "enable PNG support"
-       default y
-       depends on BR2_PACKAGE_DIRECTFB
-       select BR2_PACKAGE_LIBPNG
-
 config BR2_PACKAGE_DIRECTFB_TSLIB
        bool "enable touchscreen support"
        default y
@@ -89,3 +83,17 @@ config BR2_PACKAGE_DIRECTFB_JPEG
        default y
        depends on BR2_PACKAGE_DIRECTFB
        select BR2_PACKAGE_JPEG
+
+config BR2_PACKAGE_DIRECTFB_PNG
+       bool "enable PNG support"
+       default y
+       depends on BR2_PACKAGE_DIRECTFB
+       select BR2_PACKAGE_LIBPNG
+
+config BR2_PACKAGE_DIRECTB_DITHER_RGB16
+       bool "enable advanced dithering of RGB16 surfaces"
+       default n
+       depends on BR2_PACKAGE_DIRECTFB
+       help
+         Enable dithering when loading images to RGB16 surfaces.
+         This increases the data section by 64 KBytes.
index a85564b465cc51583f88d431bb2560360399ba45..282661591ac5aa030292e113c98e18c5a08753b9 100644 (file)
@@ -3,11 +3,9 @@
 # directfb
 #
 #############################################################
-DIRECTFB_VERSION_MAJOR:=1.2
-DIRECTFB_VERSION:=1.2.8
-#DIRECTFB_VERSION:=1.3.0       is a development version
-#DIRECTFB_VERSION_MAJOR:=1.3
-DIRECTFB_SITE:=http://www.directfb.org/downloads/Core
+DIRECTFB_VERSION_MAJOR:=1.4
+DIRECTFB_VERSION:=1.4.0
+DIRECTFB_SITE:=http://www.directfb.org/downloads/Core/DirectFB-$(DIRECTFB_VERSION_MAJOR)
 DIRECTFB_SOURCE:=DirectFB-$(DIRECTFB_VERSION).tar.gz
 DIRECTFB_AUTORECONF = NO
 DIRECTFB_LIBTOOL_PATCH = NO
@@ -99,6 +97,12 @@ else
 DIRECTFB_JPEG:=--disable-jpeg
 endif
 
+ifeq ($(BR2_PACKAGE_DIRECTB_DITHER_RGB16),y)
+DIRECTFB_DITHER_RGB16:=--with-dither-rgb16=advanced
+else
+DIRECTFB_DITHER_RGB16:=--with-dither-rgb16=none
+endif
+
 DIRECTFB_CONF_OPT = \
        --localstatedir=/var \
        --with-gfxdrivers=$(DIRECTFB_GFX) \
@@ -112,6 +116,7 @@ DIRECTFB_CONF_OPT = \
        $(DIRECTFB_PNG) \
        $(DIRECTFB_GIF) \
        $(DIRECTFB_UNIQUE) \
+       $(DIRECTFB_DITHER_RGB16) \
        --enable-linux-input \
        --enable-zlib \
        --enable-freetype \