package/optee-test: add deps on openssl when enabled
authorEtienne Carriere <etienne.carriere@linaro.org>
Fri, 30 Oct 2020 07:50:44 +0000 (08:50 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 6 Mar 2021 23:10:08 +0000 (00:10 +0100)
Add a dependency on openssl upon BR2_PACKAGE_LIBOPENSSL=y to
enable some for OP-TEE embedded tests.

Building with libressl makes the optee-test test tool fail on a
certificate test; so we explicitly depend on libopenssl.

Signed-off-by: Etienne Carriere <etienne.carriere@linaro.org>
[yann.morin.1998@free.fr:
  - match the depenency to libopenssl, since that's is what is used in
    the condition (BR2_PACKAGE_LIBOPENSSL)
  - add a blurb to explain why libopenssl is used, not the virutal
    openssl
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/optee-test/optee-test.mk

index 2304b1592549e7c29d07a074b5cf8dbe954bee57..a2d18dadfc5cc52a63a85ef290fba78e26da6e91 100644 (file)
@@ -11,6 +11,10 @@ OPTEE_TEST_LICENSE_FILES = LICENSE.md
 
 OPTEE_TEST_DEPENDENCIES = optee-client optee-os
 
+ifeq ($(BR2_PACKAGE_LIBOPENSSL),y)
+OPTEE_TEST_DEPENDENCIES += libopenssl
+endif
+
 OPTEE_TEST_CONF_OPTS = -DOPTEE_TEST_SDK=$(OPTEE_OS_SDK)
 
 # Trusted Application are not built from CMake due to ta_dev_kit