toolchain/toolchain-wrapper: explicitly pass --build-id=none if BR2_REPRODUCIBLE
authorAtharva Lele <itsatharva@gmail.com>
Sat, 31 Aug 2019 18:01:12 +0000 (23:31 +0530)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 26 Oct 2019 14:56:23 +0000 (16:56 +0200)
Build ID is added to binaries at link time. Building in different
output directories causes some packages to have different Build IDs,
thus resulting in non-reproducibility.

Adding "-Wl,--build-id=none" fixes this issue by disabling setting of
Build ID.

Diffoscope output for Build ID issue:
https://gitlab.com/snippets/1886180/raw

After this patch, build is reproducible - i.e. diffoscope does not
produce any output.

Signed-off-by: Atharva Lele <itsatharva@gmail.com>
Reviewed-by: Romain Naour <romain.naour@smile.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
toolchain/toolchain-wrapper.mk

index 970bde76a04d201638abb4732e6c5b583083f0a7..88695a5b2dc7007ab3f20190cfcb1e48fc3c591a 100644 (file)
@@ -21,6 +21,10 @@ TOOLCHAIN_WRAPPER_OPTS = \
        $(call qstrip,$(BR2_SSP_OPTION)) \
        $(call qstrip,$(BR2_TARGET_OPTIMIZATION))
 
+ifeq ($(BR2_REPRODUCIBLE),y)
+TOOLCHAIN_WRAPPER_OPTS += -Wl,--build-id=none
+endif
+
 # We create a list like '"-mfoo", "-mbar", "-mbarfoo"' so that each flag is a
 # separate argument when used in execv() by the toolchain wrapper.
 TOOLCHAIN_WRAPPER_ARGS += \