package/wpa_supplicant: fix AP mode settings
authorSergey Matyukevich <geomatsi@gmail.com>
Mon, 9 Sep 2019 20:20:34 +0000 (23:20 +0300)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 21 Sep 2019 16:00:50 +0000 (18:00 +0200)
New wpa_supplicant v2.9 enables by default AP, P2P, WIFI_DISPLAY
features in defconfig. However these features make sense only for
wpa_supplicant drivers supporting AP mode.

That is why, for consistent configuration, these features should
be explicitely disabled in wpa_supplicant .config file unless
they are requested by Config.in options.

Note that at the moment AP support in Buildroot can be enabled
only for NL80211 driver.

Fixes:
http://autobuild.buildroot.net/results/d37672374db935ac29953263ec68a2786ee65cc2/

Signed-off-by: Sergey Matyukevich <geomatsi@gmail.com>
Tested-by: Matt Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/wpa_supplicant/wpa_supplicant.mk

index 283c006052bec362802a4eed21312f9e86730f8a..9dcebca9bf6e84275820c278cbaee33346fd073f 100644 (file)
@@ -67,10 +67,16 @@ ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_AP_SUPPORT),y)
 WPA_SUPPLICANT_CONFIG_ENABLE += \
        CONFIG_AP \
        CONFIG_P2P
+else
+WPA_SUPPLICANT_CONFIG_DISABLE += \
+       CONFIG_AP \
+       CONFIG_P2P
 endif
 
 ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_WIFI_DISPLAY),y)
 WPA_SUPPLICANT_CONFIG_ENABLE += CONFIG_WIFI_DISPLAY
+else
+WPA_SUPPLICANT_CONFIG_DISABLE += CONFIG_WIFI_DISPLAY
 endif
 
 ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_MESH_NETWORKING),y)