Fixup g++ to prevent gcc_target having a missing
authorEric Andersen <andersen@codepoet.org>
Thu, 21 Nov 2002 05:17:40 +0000 (05:17 -0000)
committerEric Andersen <andersen@codepoet.org>
Thu, 21 Nov 2002 05:17:40 +0000 (05:17 -0000)
dl_iterate_phdr symbol.  Add a target 'cc' link to gcc.
 -Erik

make/gcc_target.mk
make/uclibc_toolchain.mk

index ab940fe9d16ec6893afbc5945551176811036047..956a9b0df4328f3d774190bd88111055fa245999 100644 (file)
@@ -139,6 +139,7 @@ $(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR3)/.compiled
                -C $(GCC_BUILD_DIR3) install;
        rm -rf $(TARGET_DIR)/usr/info $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc \
                $(TARGET_DIR)/usr/share/locale
+       (cd $(TARGET_DIR)/usr/bin; ln -s gcc cc)
        -$(STRIP) $(TARGET_DIR)/bin/* 
        -$(STRIP) $(TARGET_DIR)/usr/bin/* 
 
index 2dc6833f02ad34551b6dc7db2e0ee1771a5feed3..36a9d3dfbad638e9cbda73a3eac67020831dc180 100644 (file)
@@ -326,6 +326,9 @@ $(GCC_DIR)/.ldso_hacks: $(GCC_DIR)/.patched
                $(GCC_DIR)/libstdc++-v3/config/os/gnu-linux/bits/
        cp $(GCC_DIR)/libstdc++-v3/config/os/generic/bits/ctype_noninline.h \
                $(GCC_DIR)/libstdc++-v3/config/os/gnu-linux/bits/
+       # Prevent gcc from using the unwind-dw2-fde-glibc code
+       perl -i -p -e "s,^#ifndef inhibit_libc,#define inhibit_libc\n#ifndef inhibit_libc,g;" \
+               $(GCC_DIR)/gcc/unwind-dw2-fde-glibc.c;
        touch $(GCC_DIR)/.ldso_hacks
 
 $(GCC_BUILD_DIR2)/.configured: $(GCC_DIR)/.ldso_hacks