boot/at91bootstrap3: bump to v3.7.1
authorAngelo Compagnucci <angelo.compagnucci@gmail.com>
Wed, 3 Dec 2014 16:18:25 +0000 (17:18 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 7 Dec 2014 22:00:34 +0000 (23:00 +0100)
Change to use the _defconfig targets of at91bootstrap3 build system
when a defconfig is used.

[Thomas: adjust to make a better use of at91bootstrap3 defconfig
mechanism.]

Signed-off-by: Angelo Compagnucci <angelo.compagnucci@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/at91bootstrap3/at91bootstrap3.mk

index bc8d9126d7159f3e9f860ab25e023481f83c0139..098e7bfe3afe38a674d3303856b8da1197cb7de6 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-AT91BOOTSTRAP3_VERSION = v3.6.2
+AT91BOOTSTRAP3_VERSION = v3.7.1
 AT91BOOTSTRAP3_SITE = $(call github,linux4sam,at91bootstrap,$(AT91BOOTSTRAP3_VERSION))
 
 AT91BOOTSTRAP3_INSTALL_IMAGES = YES
@@ -29,19 +29,17 @@ AT91BOOTSTRAP3_POST_PATCH_HOOKS += AT91BOOTSTRAP3_APPLY_CUSTOM_PATCHES
 endif
 
 ifeq ($(BR2_TARGET_AT91BOOTSTRAP3_USE_DEFCONFIG),y)
-AT91BOOTSTRAP3_SOURCE_CONFIG = \
-       $(@D)/board/*/$(AT91BOOTSTRAP3_DEFCONFIG)_defconfig
+define AT91BOOTSTRAP3_CONFIGURE_CMDS
+       $(MAKE) $(AT91BOOTSTRAP3_MAKE_OPTS) -C $(@D) $(AT91BOOTSTRAP3_DEFCONFIG)_defconfig
+endef
 else ifeq ($(BR2_TARGET_AT91BOOTSTRAP3_USE_CUSTOM_CONFIG),y)
-AT91BOOTSTRAP3_SOURCE_CONFIG = $(AT91BOOTSTRAP3_CUSTOM_CONFIG_FILE)
-endif
-
 define AT91BOOTSTRAP3_CONFIGURE_CMDS
-       cp $(AT91BOOTSTRAP3_SOURCE_CONFIG) $(@D)/.config
-       $(SED) 's/image.bin/uImage/' $(@D)/.config
+       cp $(BR2_TARGET_AT91BOOTSTRAP3_CUSTOM_CONFIG_FILE) $(@D)/.config
 endef
+endif
 
 define AT91BOOTSTRAP3_BUILD_CMDS
-       $(MAKE) $(AT91BOOTSTRAP3_MAKE_OPTS) -C $(@D) boot
+       $(MAKE) $(AT91BOOTSTRAP3_MAKE_OPTS) -C $(@D)
 endef
 
 define AT91BOOTSTRAP3_INSTALL_IMAGES_CMDS