Remove unwanted docs
authorEric Andersen <andersen@codepoet.org>
Fri, 14 Feb 2003 12:20:38 +0000 (12:20 -0000)
committerEric Andersen <andersen@codepoet.org>
Fri, 14 Feb 2003 12:20:38 +0000 (12:20 -0000)
make/autoconf.mk
make/automake.mk
make/gdb.mk
make/gdbserver.mk
make/libtool.mk
make/m4.mk

index 92b4df36d55daf2e917e07169c592322eafa60a7..fe11b2c7d866797bb56518e35d46a243cb03474f 100644 (file)
@@ -55,7 +55,8 @@ $(TARGET_DIR)/$(AUTOCONF_TARGET_BINARY): $(AUTOCONF_DIR)/bin/$(AUTOCONF_BINARY)
            mandir=$(TARGET_DIR)/usr/man \
            includedir=$(TARGET_DIR)/usr/include \
            -C $(AUTOCONF_DIR) install;
-       rm -rf $(TARGET_DIR)/share/locale
+       rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+               $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
 
 autoconf: uclibc $(TARGET_DIR)/$(AUTOCONF_TARGET_BINARY)
 
index bc226c10f42c9d5483329e82bbb298d6be41be10..6d4bbaa7d673c92413dfe26bfc42ee3eee0ad6fe 100644 (file)
@@ -56,7 +56,8 @@ $(TARGET_DIR)/$(AUTOMAKE_TARGET_BINARY): $(AUTOMAKE_DIR)/$(AUTOMAKE_BINARY)
            mandir=$(TARGET_DIR)/usr/man \
            includedir=$(TARGET_DIR)/usr/include \
            -C $(AUTOMAKE_DIR) install;
-       rm -rf $(TARGET_DIR)/share/locale
+       rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+               $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
        touch -c $(TARGET_DIR)/$(AUTOMAKE_TARGET_BINARY)
 
 automake: uclibc $(TARGET_DIR)/$(AUTOMAKE_TARGET_BINARY)
index 5b6650af767063880f97bb8acb4e74acf03c2fb5..8d54f82260cfb440830df79e122592e10dc4760b 100644 (file)
@@ -49,6 +49,8 @@ $(GDB_DIR)/gdb/gdb: $(GDB_DIR)/.configured
 
 $(TARGET_DIR)/usr/bin/gdb: $(GDB_DIR)/gdb/gdb
        install -c $(GDB_DIR)/gdb/gdb $(TARGET_DIR)/usr/bin/gdb
+       rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+               $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
 
 gdb: $(TARGET_DIR)/usr/bin/gdb
 
index c1ef1f1aa2be99080a9e077dd8f68696730b2e9d..bafd4d9e1792bfe3298bd856c6000a064766bfaa 100644 (file)
@@ -42,6 +42,8 @@ $(GDB_WDIR)/gdbserver: $(GDB_WDIR)/.configured
 
 $(TARGET_DIR)/usr/bin/gdbserver: $(GDB_WDIR)/gdbserver
        install -c $(GDB_WDIR)/gdbserver $(TARGET_DIR)/usr/bin/gdbserver
+       rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+               $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
 
 gdbserver: $(TARGET_DIR)/usr/bin/gdbserver
 
index 6043f5285625f0a2d6f82e595603bc7f1fe6ed6d..126b720d8476f574336e3f53db6c22ab22b39752 100644 (file)
@@ -59,7 +59,8 @@ $(TARGET_DIR)/$(LIBTOOL_TARGET_BINARY): $(LIBTOOL_DIR)/$(LIBTOOL_BINARY)
            -C $(LIBTOOL_DIR) install;
        perl -pi -e "s,^CC.*,CC=\"/usr/bin/gcc\"," $(TARGET_DIR)/usr/bin/libtool
        perl -pi -e "s,^LD.*,LD=\"/usr/bin/ld\"," $(TARGET_DIR)/usr/bin/libtool
-       rm -rf $(TARGET_DIR)/share/locale
+       rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+               $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
 
 libtool: uclibc $(TARGET_DIR)/$(LIBTOOL_TARGET_BINARY)
 
index 8be5ddedb1e1d77e2b70921eb13a917fec71d40c..e435386e921c499c058b2f2b36ba30c38cfc51f3 100644 (file)
@@ -47,7 +47,8 @@ $(TARGET_DIR)/$(M4_TARGET_BINARY): $(M4_DIR)/src/$(M4_BINARY)
            mandir=$(TARGET_DIR)/usr/man \
            includedir=$(TARGET_DIR)/usr/include \
            -C $(M4_DIR) install;
-       rm -rf $(TARGET_DIR)/share/locale
+       rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+               $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
 
 m4: uclibc $(TARGET_DIR)/$(M4_TARGET_BINARY)