package/liburiparser: New package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 23 Nov 2014 19:56:51 +0000 (20:56 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 26 Nov 2014 21:45:00 +0000 (22:45 +0100)
[Thomas:
 - put liburiparser at the right place in package/Config.in, i.e
   sorted alphabetically
 - use positive logic for the wchar test.]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/liburiparser/Config.in [new file with mode: 0644]
package/liburiparser/liburiparser.hash [new file with mode: 0644]
package/liburiparser/liburiparser.mk [new file with mode: 0644]

index bb5b144e82972e400c7b15fdc39fda5bc24481a9..b8fc7d15af0b0ed3a533eb5a0f1d906041a08413 100644 (file)
@@ -837,6 +837,7 @@ menu "Networking"
        source "package/libtorrent/Config.in"
        source "package/libupnp/Config.in"
        source "package/libupnpp/Config.in"
+       source "package/liburiparser/Config.in"
        source "package/libvncserver/Config.in"
        source "package/libwebsockets/Config.in"
        source "package/neon/Config.in"
diff --git a/package/liburiparser/Config.in b/package/liburiparser/Config.in
new file mode 100644 (file)
index 0000000..95a6fe8
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_LIBURIPARSER
+       bool "liburiparser"
+       help
+         uriparser is a strictly RFC 3986 compliant URI parsing and handling
+         library written in C.
+
+         http://uriparser.sourceforge.net
diff --git a/package/liburiparser/liburiparser.hash b/package/liburiparser/liburiparser.hash
new file mode 100644 (file)
index 0000000..84340f8
--- /dev/null
@@ -0,0 +1,3 @@
+# From http://sourceforge.net/projects/uriparser/files/Sources/0.8.1/
+md5    4e4c5f0ee6abb111a431c45e144247aa                uriparser-0.8.1.tar.bz2
+sha1   4405d8baa0d9f5bc0319e6d5e68770acab67b602        uriparser-0.8.1.tar.bz2
diff --git a/package/liburiparser/liburiparser.mk b/package/liburiparser/liburiparser.mk
new file mode 100644 (file)
index 0000000..661fa96
--- /dev/null
@@ -0,0 +1,19 @@
+################################################################################
+#
+# liburiparser
+#
+################################################################################
+
+LIBURIPARSER_VERSION = 0.8.1
+LIBURIPARSER_SOURCE = uriparser-$(LIBURIPARSER_VERSION).tar.bz2
+LIBURIPARSER_SITE = http://sourceforge.net/projects/uriparser/files/Sources/$(LIBURIPARSER_VERSION)
+LIBURIPARSER_LICENSE = BSD-3c
+LIBURIPARSER_LICENSE_FILES = COPYING
+LIBURIPARSER_INSTALL_STAGING = YES
+LIBURIPARSER_CONF_OPTS = --disable-test
+
+ifeq ($(BR2_USE_WCHAR),)
+LIBURIPARSER_CONF_OPTS += --disable-wchar_t
+endif
+
+$(eval $(autotools-package))